Tango FSE Procedures API

Welcome

Welcome to the Tango FSE Procedures API documentation.

This document contains a detailed description of each part of the API with some examples.

The best way to start exploring the main capabilities of a procedure is the IProcedureContext interface.

What is a Procedure ?

  • A procedure is a sequence of a pre-programmed actions/commands.

  • A procedure can have one or more user input parameters.

  • A procedure can have one or more output values.

Procedures are not legacy “stubs”. They are a completely different creature.
Procedures are a way for providing immediate and dynamic response for almost any scenario or issue that is being raised by customers/technicians.
Procedure programmers can leverage an intuitive and extensive API and accomplish almost any requirement.
Programming and managing Procedures is done through the “Procedure Designer” module.

The Procedure Designer

The procedure designer module can be seen as a fully fledged IDE (Integrated Development Environment), designed to provide the best development experience for the “procedure programmer”.

The procedure designer is basically a project editor. In the technical sense, a “Procedure” is basically a project.

A project can be composed of one or more script files that are automatically linked together.

A project, is represented as a single file (.pproj) and is designed to encapsulate all the files and information about the project.

A project can have multiple assembly references and make use of them. An assembly reference can be any DLL file from the entire .NET framework, or from Twine’s libraries.

A “Procedure” in the “Procedures Module” is actually a single published procedure project.
A published procedure is a project that is saved on Twine’s global database (per environment).
Each published project has a name, description and version, while preserving the history of the last 10 versions.
When the user navigates to the Procedures Module, Tango FSE will retrieves all published projects from the server.

Accessing the procedure designer module requires the “Run Procedure Designer” permission.
Publishing a procedure project requires the “Publish Procedure Projects” permission.

Summery:

  • Published procedure projects are intended for all users and can be executed using the Procedures Module.

  • Procedure Project files are intended for Twine’s programmers and technicians and can be executed/edited using the Procedure Designer.

We can say that once a procedure project that is being designed for end-users, is well-tested and optimized, it can be published and be available as a “Procedure” for end-users.


Tango.DataStore Namespace

Classes
 | Class | Description
Public class | DataStoreProtoObject |
Interfaces
 | Interface | Description
Public interface | IDataStoreCollection | Represents a data store collection.
Public interface | IDataStoreItem | Represents a data store item.
Public interface | IDataStoreManager | Represents a key/value data store manager.
Enumerations
 | Enumeration | Description
Public enumeration | DataType | Represents a data store item type.


DataStoreProtoObject Class

[Missing <summary> documentation for "T:Tango.DataStore.DataStoreProtoObject"]

Inheritance Hierarchy
SystemObject
Tango.DataStoreDataStoreProtoObject

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public class DataStoreProtoObject

The DataStoreProtoObject type exposes the following members.

Constructors
 | Name | Description
Public method | DataStoreProtoObject | Initializes a new instance of the DataStoreProtoObject class
Top
Properties
 | Name | Description
Public property | Data |
Public property | Message |
Public property | MessageType |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromBytes |
 | FromJObject |
 | FromMessage |
 | FromPMRDataStoreItem |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToBytes |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Tango.DataStore Namespace


DataStoreProtoObject Constructor

Initializes a new instance of the DataStoreProtoObject class

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public DataStoreProtoObject()
See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject Properties

The DataStoreProtoObject type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Public property | Message |
Public property | MessageType |
Public property | Type |
Top
See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.Data Property

DataStoreProtoObjectData Property

[Missing <summary> documentation for "P:Tango.DataStore.DataStoreProtoObject.Data"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public byte[] Data { get; set; }

Property Value

Type: Byte
See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.Message Property

DataStoreProtoObjectMessage Property

[Missing <summary> documentation for "P:Tango.DataStore.DataStoreProtoObject.Message"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public IMessage Message { get; }

Property Value

Type: IMessage
See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.MessageType Property

DataStoreProtoObjectMessageType Property

[Missing <summary> documentation for "P:Tango.DataStore.DataStoreProtoObject.MessageType"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public DataStoreMessageType MessageType { get; set; }

Property Value

Type: DataStoreMessageType
See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.Type Property

DataStoreProtoObjectType Property

[Missing <summary> documentation for "P:Tango.DataStore.DataStoreProtoObject.Type"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public Type Type { get; set; }

Property Value

Type: Type
See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject Methods

The DataStoreProtoObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FromBytes |
 | FromJObject |
 | FromMessage |
 | FromPMRDataStoreItem |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToBytes |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.FromBytes Method

DataStoreProtoObjectFromBytes Method

[Missing <summary> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromBytes(System.Byte[])"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public static DataStoreProtoObject FromBytes(
    byte[] data
)

Parameters

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromBytes(System.Byte[])"]

Return Value

Type: DataStoreProtoObject

[Missing <returns> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromBytes(System.Byte[])"]

See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.FromJObject Method

DataStoreProtoObjectFromJObject Method

[Missing <summary> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromJObject(Newtonsoft.Json.Linq.JObject)"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public static DataStoreProtoObject FromJObject(
    JObject obj
)

Parameters

obj
Type: JObject

[Missing <param name="obj"/> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromJObject(Newtonsoft.Json.Linq.JObject)"]

Return Value

Type: DataStoreProtoObject

[Missing <returns> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromJObject(Newtonsoft.Json.Linq.JObject)"]

See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.FromMessage Method

DataStoreProtoObjectFromMessage Method

[Missing <summary> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromMessage(Google.Protobuf.IMessage)"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public static DataStoreProtoObject FromMessage(
    IMessage message
)

Parameters

message
Type: IMessage

[Missing <param name="message"/> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromMessage(Google.Protobuf.IMessage)"]

Return Value

Type: DataStoreProtoObject

[Missing <returns> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromMessage(Google.Protobuf.IMessage)"]

See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.FromPMRDataStoreItem Method

DataStoreProtoObjectFromPMRDataStoreItem Method

[Missing <summary> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromPMRDataStoreItem(Tango.PMR.DataStore.DataStoreItem)"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public static DataStoreProtoObject FromPMRDataStoreItem(
    DataStoreItem item
)

Parameters

item
Type: DataStoreItem

[Missing <param name="item"/> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromPMRDataStoreItem(Tango.PMR.DataStore.DataStoreItem)"]

Return Value

Type: DataStoreProtoObject

[Missing <returns> documentation for "M:Tango.DataStore.DataStoreProtoObject.FromPMRDataStoreItem(Tango.PMR.DataStore.DataStoreItem)"]

See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.ToBytes Method

DataStoreProtoObjectToBytes Method

[Missing <summary> documentation for "M:Tango.DataStore.DataStoreProtoObject.ToBytes"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public byte[] ToBytes()

Return Value

Type: Byte

[Missing <returns> documentation for "M:Tango.DataStore.DataStoreProtoObject.ToBytes"]

See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataStoreProtoObject.ToString Method

DataStoreProtoObjectToString Method

[Missing <summary> documentation for "M:Tango.DataStore.DataStoreProtoObject.ToString"]

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.DataStore.DataStoreProtoObject.ToString"]

See Also

Reference

DataStoreProtoObject Class
Tango.DataStore Namespace


DataType Enumeration

Represents a data store item type.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public enum DataType
Members
Member name | Value | Description
Int32 | 0 |
Float | 1 |
Double | 2 |
Boolean | 3 |
String | 4 |
Bytes | 5 |
Proto | 6 |
See Also

Reference

Tango.DataStore Namespace


IDataStoreCollection Interface

Represents a data store collection.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public interface IDataStoreCollection

The IDataStoreCollection type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the collection name.
Top
Methods
 | Name | Description
Public method | Count | Returns the number of items in the collection.
Public method | Delete | Deleted an item by the specified key.
Public method | DeleteAll | Deletes all items in the collection.
Public method | Get(String) | Gets the value by the specified key
Public method | Get(String, Object) | Gets the value by the specified key
Public method | GetT(String) | Gets the value of type T by the specified key
Public method | GetT(String, T) | Gets the value of type T by the specified key
Public method | GetAll | Gets all the data store items in the collection.
Public method | GetItem(String) | Gets the full data store item by the specified key.
Public method | GetItem(String, Object) | Gets the full data store item by the specified key.
Public method | GetUnsynchronized | Gets all the data store unsynchronized items in the collection.
Public method | Put(String, Object) | Upserts the specified key and value.
Public method | Put(String, DataType, Object) | Upserts the specified key and value. The value must be of the specified DataType.
Public method | PutT(String, T) | Upserts the specified key and value of type T.
Top
See Also

Reference

Tango.DataStore Namespace


IDataStoreCollection Properties

The IDataStoreCollection type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the collection name.
Top
See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.Name Property

IDataStoreCollectionName Property

Gets the collection name.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection Methods

The IDataStoreCollection type exposes the following members.

Methods
 | Name | Description
Public method | Count | Returns the number of items in the collection.
Public method | Delete | Deleted an item by the specified key.
Public method | DeleteAll | Deletes all items in the collection.
Public method | Get(String) | Gets the value by the specified key
Public method | Get(String, Object) | Gets the value by the specified key
Public method | GetT(String) | Gets the value of type T by the specified key
Public method | GetT(String, T) | Gets the value of type T by the specified key
Public method | GetAll | Gets all the data store items in the collection.
Public method | GetItem(String) | Gets the full data store item by the specified key.
Public method | GetItem(String, Object) | Gets the full data store item by the specified key.
Public method | GetUnsynchronized | Gets all the data store unsynchronized items in the collection.
Public method | Put(String, Object) | Upserts the specified key and value.
Public method | Put(String, DataType, Object) | Upserts the specified key and value. The value must be of the specified DataType.
Public method | PutT(String, T) | Upserts the specified key and value of type T.
Top
See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.Count Method

IDataStoreCollectionCount Method

Returns the number of items in the collection.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
int Count()

Return Value

Type: Int32

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreCollection.Count"]

See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.Delete Method

IDataStoreCollectionDelete Method

Deleted an item by the specified key.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
void Delete(
    string key
)

Parameters

key
Type: SystemString
The key.
See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.DeleteAll Method

IDataStoreCollectionDeleteAll Method

Deletes all items in the collection.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
void DeleteAll()
See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.Get Method

IDataStoreCollectionGet Method

Overload List
 | Name | Description
Public method | Get(String) | Gets the value by the specified key
Public method | GetT(String) | Gets the value of type T by the specified key
Public method | Get(String, Object) | Gets the value by the specified key
Public method | GetT(String, T) | Gets the value of type T by the specified key
Top
See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.Get Method (String)

IDataStoreCollectionGet Method (String)

Gets the value by the specified key

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
Object Get(
    string key
)

Parameters

key
Type: SystemString
The key.

Return Value

Type: Object

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreCollection.Get(System.String)"]

See Also

Reference

IDataStoreCollection Interface
Get Overload
Tango.DataStore Namespace


IDataStoreCollection.Get(T) Method (String)

IDataStoreCollectionGetT Method (String)

Gets the value of type T by the specified key

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
T Get<T>(
    string key
)

Parameters

key
Type: SystemString
The key.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.DataStore.IDataStoreCollection.Get``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreCollection.Get``1(System.String)"]

See Also

Reference

IDataStoreCollection Interface
Get Overload
Tango.DataStore Namespace


IDataStoreCollection.Get Method (String, Object)

IDataStoreCollectionGet Method (String, Object)

Gets the value by the specified key

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
Object Get(
    string key,
    Object defaultValue
)

Parameters

key
Type: SystemString
The key.
defaultValue
Type: SystemObject
Will execute put when the key was not found.

Return Value

Type: Object

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreCollection.Get(System.String,System.Object)"]

See Also

Reference

IDataStoreCollection Interface
Get Overload
Tango.DataStore Namespace


IDataStoreCollection.Get(T) Method (String, T)

IDataStoreCollectionGetT Method (String, T)

Gets the value of type T by the specified key

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
T Get<T>(
    string key,
    T defaultValue
)

Parameters

key
Type: SystemString
The key.
defaultValue
Type: T
Will execute put when the key was not found.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.DataStore.IDataStoreCollection.Get``1(System.String,``0)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreCollection.Get``1(System.String,``0)"]

See Also

Reference

IDataStoreCollection Interface
Get Overload
Tango.DataStore Namespace


IDataStoreCollection.GetAll Method

IDataStoreCollectionGetAll Method

Gets all the data store items in the collection.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
List<IDataStoreItem> GetAll()

Return Value

Type: ListIDataStoreItem

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreCollection.GetAll"]

See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.GetItem Method

IDataStoreCollectionGetItem Method

Overload List
 | Name | Description
Public method | GetItem(String) | Gets the full data store item by the specified key.
Public method | GetItem(String, Object) | Gets the full data store item by the specified key.
Top
See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.GetItem Method (String)

IDataStoreCollectionGetItem Method (String)

Gets the full data store item by the specified key.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
IDataStoreItem GetItem(
    string key
)

Parameters

key
Type: SystemString
The key.

Return Value

Type: IDataStoreItem

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreCollection.GetItem(System.String)"]

See Also

Reference

IDataStoreCollection Interface
GetItem Overload
Tango.DataStore Namespace


IDataStoreCollection.GetItem Method (String, Object)

IDataStoreCollectionGetItem Method (String, Object)

Gets the full data store item by the specified key.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
IDataStoreItem GetItem(
    string key,
    Object defaultValue
)

Parameters

key
Type: SystemString
The key.
defaultValue
Type: SystemObject
Will execute put when the key was not found.

Return Value

Type: IDataStoreItem

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreCollection.GetItem(System.String,System.Object)"]

See Also

Reference

IDataStoreCollection Interface
GetItem Overload
Tango.DataStore Namespace


IDataStoreCollection.GetUnsynchronized Method

IDataStoreCollectionGetUnsynchronized Method

Gets all the data store unsynchronized items in the collection.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
List<IDataStoreItem> GetUnsynchronized()

Return Value

Type: ListIDataStoreItem

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreCollection.GetUnsynchronized"]

See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.Put Method

IDataStoreCollectionPut Method

Overload List
 | Name | Description
Public method | Put(String, Object) | Upserts the specified key and value.
Public method | PutT(String, T) | Upserts the specified key and value of type T.
Public method | Put(String, DataType, Object) | Upserts the specified key and value. The value must be of the specified DataType.
Top
See Also

Reference

IDataStoreCollection Interface
Tango.DataStore Namespace


IDataStoreCollection.Put Method (String, Object)

IDataStoreCollectionPut Method (String, Object)

Upserts the specified key and value.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
void Put(
    string key,
    Object value
)

Parameters

key
Type: SystemString
The key.
value
Type: SystemObject
The value.
See Also

Reference

IDataStoreCollection Interface
Put Overload
Tango.DataStore Namespace


IDataStoreCollection.Put(T) Method (String, T)

IDataStoreCollectionPutT Method (String, T)

Upserts the specified key and value of type T.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
void Put<T>(
    string key,
    T value
)

Parameters

key
Type: SystemString
The key.
value
Type: T
The value.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.DataStore.IDataStoreCollection.Put``1(System.String,``0)"]

See Also

Reference

IDataStoreCollection Interface
Put Overload
Tango.DataStore Namespace


IDataStoreCollection.Put Method (String, DataType, Object)

IDataStoreCollectionPut Method (String, DataType, Object)

Upserts the specified key and value. The value must be of the specified DataType.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
void Put(
    string key,
    DataType type,
    Object value
)

Parameters

key
Type: SystemString
The key.
type
Type: Tango.DataStoreDataType
The type.
value
Type: SystemObject
The value.
See Also

Reference

IDataStoreCollection Interface
Put Overload
Tango.DataStore Namespace


IDataStoreItem Interface

Represents a data store item.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public interface IDataStoreItem

The IDataStoreItem type exposes the following members.

Properties
 | Name | Description
Public property | Date | Gets or sets the item update UTC date.
Public property | Guid | Gets or sets the unique identifier (Use only for synchronization).
Public property | IsSynchronized | Gets or sets a value indicating whether this item is synchronized with the remote service.
Public property | Key | Gets or sets item id.
Public property | Type | Gets or sets the item type.
Public property | Value | Gets or sets the item value.
Top
See Also

Reference

Tango.DataStore Namespace


IDataStoreItem Properties

The IDataStoreItem type exposes the following members.

Properties
 | Name | Description
Public property | Date | Gets or sets the item update UTC date.
Public property | Guid | Gets or sets the unique identifier (Use only for synchronization).
Public property | IsSynchronized | Gets or sets a value indicating whether this item is synchronized with the remote service.
Public property | Key | Gets or sets item id.
Public property | Type | Gets or sets the item type.
Public property | Value | Gets or sets the item value.
Top
See Also

Reference

IDataStoreItem Interface
Tango.DataStore Namespace


IDataStoreItem.Date Property

IDataStoreItemDate Property

Gets or sets the item update UTC date.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
DateTime Date { get; set; }

Property Value

Type: DateTime
See Also

Reference

IDataStoreItem Interface
Tango.DataStore Namespace


IDataStoreItem.Guid Property

IDataStoreItemGuid Property

Gets or sets the unique identifier (Use only for synchronization).

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
string Guid { get; set; }

Property Value

Type: String
See Also

Reference

IDataStoreItem Interface
Tango.DataStore Namespace


IDataStoreItem.IsSynchronized Property

IDataStoreItemIsSynchronized Property

Gets or sets a value indicating whether this item is synchronized with the remote service.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
bool IsSynchronized { get; set; }

Property Value

Type: Boolean
See Also

Reference

IDataStoreItem Interface
Tango.DataStore Namespace


IDataStoreItem.Key Property

IDataStoreItemKey Property

Gets or sets item id.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
string Key { get; set; }

Property Value

Type: String
See Also

Reference

IDataStoreItem Interface
Tango.DataStore Namespace


IDataStoreItem.Type Property

IDataStoreItemType Property

Gets or sets the item type.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
DataType Type { get; set; }

Property Value

Type: DataType
See Also

Reference

IDataStoreItem Interface
Tango.DataStore Namespace


IDataStoreItem.Value Property

IDataStoreItemValue Property

Gets or sets the item value.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
Object Value { get; set; }

Property Value

Type: Object
See Also

Reference

IDataStoreItem Interface
Tango.DataStore Namespace


IDataStoreManager Interface

Represents a key/value data store manager.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
public interface IDataStoreManager : IDisposable

The IDataStoreManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCollection | Gets the data store collection by name.
Public method | GetCollectionNames | Gets all the collection names.
Top
See Also

Reference

Tango.DataStore Namespace
SystemIDisposable


IDataStoreManager Methods

The IDataStoreManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCollection | Gets the data store collection by name.
Public method | GetCollectionNames | Gets all the collection names.
Top
See Also

Reference

IDataStoreManager Interface
Tango.DataStore Namespace


IDataStoreManager.GetCollection Method

IDataStoreManagerGetCollection Method

Gets the data store collection by name.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
IDataStoreCollection GetCollection(
    string name
)

Parameters

name
Type: SystemString
The name.

Return Value

Type: IDataStoreCollection

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreManager.GetCollection(System.String)"]

See Also

Reference

IDataStoreManager Interface
Tango.DataStore Namespace


IDataStoreManager.GetCollectionNames Method

IDataStoreManagerGetCollectionNames Method

Gets all the collection names.

Namespace: Tango.DataStore
Assembly: Tango.DataStore (in Tango.DataStore.dll) Version: 2.0.4.1608
Syntax
C#
Copy
List<string> GetCollectionNames()

Return Value

Type: ListString

[Missing <returns> documentation for "M:Tango.DataStore.IDataStoreManager.GetCollectionNames"]

See Also

Reference

IDataStoreManager Interface
Tango.DataStore Namespace


Tango.FSE.Common.Build Namespace

Interfaces
 | Interface | Description
Public interface | IBuildProvider |
Enumerations
 | Enumeration | Description
Public enumeration | BuildVariants |


BuildVariants Enumeration

[Missing <summary> documentation for "T:Tango.FSE.Common.Build.BuildVariants"]

Namespace: Tango.FSE.Common.Build
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum BuildVariants
Members
Member name | Value | Description
FSE | 0 |
TwineRSM | 1 |
See Also

Reference

Tango.FSE.Common.Build Namespace


IBuildProvider Interface

[Missing <summary> documentation for "T:Tango.FSE.Common.Build.IBuildProvider"]

Namespace: Tango.FSE.Common.Build
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IBuildProvider

The IBuildProvider type exposes the following members.

Properties
 | Name | Description
Public property | BuildName |
Public property | CurrentBuild |
Public property | IsTwineRSM |
Top
See Also

Reference

Tango.FSE.Common.Build Namespace


IBuildProvider Properties

The IBuildProvider type exposes the following members.

Properties
 | Name | Description
Public property | BuildName |
Public property | CurrentBuild |
Public property | IsTwineRSM |
Top
See Also

Reference

IBuildProvider Interface
Tango.FSE.Common.Build Namespace


IBuildProvider.BuildName Property

IBuildProviderBuildName Property

[Missing <summary> documentation for "P:Tango.FSE.Common.Build.IBuildProvider.BuildName"]

Namespace: Tango.FSE.Common.Build
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string BuildName { get; }

Property Value

Type: String
See Also

Reference

IBuildProvider Interface
Tango.FSE.Common.Build Namespace


IBuildProvider.CurrentBuild Property

IBuildProviderCurrentBuild Property

[Missing <summary> documentation for "P:Tango.FSE.Common.Build.IBuildProvider.CurrentBuild"]

Namespace: Tango.FSE.Common.Build
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
BuildVariants CurrentBuild { get; }

Property Value

Type: BuildVariants
See Also

Reference

IBuildProvider Interface
Tango.FSE.Common.Build Namespace


IBuildProvider.IsTwineRSM Property

IBuildProviderIsTwineRSM Property

[Missing <summary> documentation for "P:Tango.FSE.Common.Build.IBuildProvider.IsTwineRSM"]

Namespace: Tango.FSE.Common.Build
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool IsTwineRSM { get; }

Property Value

Type: Boolean
See Also

Reference

IBuildProvider Interface
Tango.FSE.Common.Build Namespace


Tango.FSE.Common.Connection Namespace

Enumerations
 | Enumeration | Description
Public enumeration | MachineConnectionTypes | Represents the available machine connection end-point types.


MachineConnectionTypes Enumeration

Represents the available machine connection end-point types.

Namespace: Tango.FSE.Common.Connection
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum MachineConnectionTypes
Members
Member name | Value | Description
USB | 0 | Local USB connection.
TCP | 1 | Local TCP connection.
Wifi | 2 | Local area network.
SignalR | 3 | Via cloud/machine service.
Emulator | 4 | In-Memory emulator.
See Also

Reference

Tango.FSE.Common.Connection Namespace


Tango.FSE.Common.DataStore Namespace

Interfaces
 | Interface | Description
Public interface | IDataStoreProvider |
Public interface | IRemoteDataStoreManager |


IDataStoreProvider Interface

[Missing <summary> documentation for "T:Tango.FSE.Common.DataStore.IDataStoreProvider"]

Namespace: Tango.FSE.Common.DataStore
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IDataStoreProvider

The IDataStoreProvider type exposes the following members.

Properties
 | Name | Description
Public property | AcceptFirmwareChanges |
Top
Methods
 | Name | Description
Public method | GetDataStoreModel |
Public method | UpdateDataStoreModel |
Top
See Also

Reference

Tango.FSE.Common.DataStore Namespace


IDataStoreProvider Properties

The IDataStoreProvider type exposes the following members.

Properties
 | Name | Description
Public property | AcceptFirmwareChanges |
Top
See Also

Reference

IDataStoreProvider Interface
Tango.FSE.Common.DataStore Namespace


IDataStoreProvider.AcceptFirmwareChanges Property

IDataStoreProviderAcceptFirmwareChanges Property

[Missing <summary> documentation for "P:Tango.FSE.Common.DataStore.IDataStoreProvider.AcceptFirmwareChanges"]

Namespace: Tango.FSE.Common.DataStore
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool AcceptFirmwareChanges { get; set; }

Property Value

Type: Boolean
See Also

Reference

IDataStoreProvider Interface
Tango.FSE.Common.DataStore Namespace


IDataStoreProvider Methods

The IDataStoreProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetDataStoreModel |
Public method | UpdateDataStoreModel |
Top
See Also

Reference

IDataStoreProvider Interface
Tango.FSE.Common.DataStore Namespace


IDataStoreProvider.GetDataStoreModel Method

IDataStoreProviderGetDataStoreModel Method

[Missing <summary> documentation for "M:Tango.FSE.Common.DataStore.IDataStoreProvider.GetDataStoreModel(System.String)"]

Namespace: Tango.FSE.Common.DataStore
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task<DataStoreModel> GetDataStoreModel(
    string machineGuid
)

Parameters

machineGuid
Type: SystemString

[Missing <param name="machineGuid"/> documentation for "M:Tango.FSE.Common.DataStore.IDataStoreProvider.GetDataStoreModel(System.String)"]

Return Value

Type: TaskDataStoreModel

[Missing <returns> documentation for "M:Tango.FSE.Common.DataStore.IDataStoreProvider.GetDataStoreModel(System.String)"]

See Also

Reference

IDataStoreProvider Interface
Tango.FSE.Common.DataStore Namespace


IDataStoreProvider.UpdateDataStoreModel Method

IDataStoreProviderUpdateDataStoreModel Method

[Missing <summary> documentation for "M:Tango.FSE.Common.DataStore.IDataStoreProvider.UpdateDataStoreModel(Tango.DataStore.Editing.DataStoreModel,System.String)"]

Namespace: Tango.FSE.Common.DataStore
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task<DataStoreModel> UpdateDataStoreModel(
    DataStoreModel model,
    string machineGuid
)

Parameters

model
Type: DataStoreModel

[Missing <param name="model"/> documentation for "M:Tango.FSE.Common.DataStore.IDataStoreProvider.UpdateDataStoreModel(Tango.DataStore.Editing.DataStoreModel,System.String)"]

machineGuid
Type: SystemString

[Missing <param name="machineGuid"/> documentation for "M:Tango.FSE.Common.DataStore.IDataStoreProvider.UpdateDataStoreModel(Tango.DataStore.Editing.DataStoreModel,System.String)"]

Return Value

Type: TaskDataStoreModel

[Missing <returns> documentation for "M:Tango.FSE.Common.DataStore.IDataStoreProvider.UpdateDataStoreModel(Tango.DataStore.Editing.DataStoreModel,System.String)"]

See Also

Reference

IDataStoreProvider Interface
Tango.FSE.Common.DataStore Namespace


IRemoteDataStoreManager Interface

[Missing <summary> documentation for "T:Tango.FSE.Common.DataStore.IRemoteDataStoreManager"]

Namespace: Tango.FSE.Common.DataStore
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IRemoteDataStoreManager : IDataStoreManager,
    IDisposable

The IRemoteDataStoreManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCollection | Gets the data store collection by name. (Inherited from IDataStoreManager.)
Public method | GetCollectionNames | Gets all the collection names. (Inherited from IDataStoreManager.)
Top
See Also

Reference

Tango.FSE.Common.DataStore Namespace


IRemoteDataStoreManager Methods

The IRemoteDataStoreManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCollection | Gets the data store collection by name. (Inherited from IDataStoreManager.)
Public method | GetCollectionNames | Gets all the collection names. (Inherited from IDataStoreManager.)
Top
See Also

Reference

IRemoteDataStoreManager Interface
Tango.FSE.Common.DataStore Namespace


Tango.FSE.Common.Diagnostics Namespace

Classes
 | Class | Description
Public class | DiagnosticsPackage | Represents a machine diagnostics frame package.


DiagnosticsPackage Class

Represents a machine diagnostics frame package.
Inheritance Hierarchy
SystemObject
Tango.FSE.Common.DiagnosticsDiagnosticsPackage

Namespace: Tango.FSE.Common.Diagnostics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class DiagnosticsPackage

The DiagnosticsPackage type exposes the following members.

Constructors
 | Name | Description
Public method | DiagnosticsPackage | Initializes a new instance of the DiagnosticsPackage class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDigitalInterfaceState | Gets the state of the digital interface.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHeaterState | Gets the state of the specified heater.
Public method | GetMonitorArray | Gets the data array from a protobuf repeated monitor by the specified TechMonitors enumeration.
Public method | GetMonitorLastValue | Gets the last data point of a repeated field monitor by the specified TechMonitors enumeration.
Public method | GetMonitorMatrix | Gets the data matrix from a protobuf repeated field of DoubleArray.
Public method | GetMonitorObject | Gets the monitor value by the specified TechMonitors enumeration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValveState | Gets the state of the specified valve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.FSE.Common.Diagnostics Namespace


DiagnosticsPackage Constructor

Initializes a new instance of the DiagnosticsPackage class.

Namespace: Tango.FSE.Common.Diagnostics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DiagnosticsPackage(
    DiagnosticsFrame frame
)

Parameters

frame
Type: DiagnosticsFrame

[Missing <param name="frame"/> documentation for "M:Tango.FSE.Common.Diagnostics.DiagnosticsPackage.#ctor(Tango.FSE.Common.Diagnostics.DiagnosticsFrame)"]

See Also

Reference

DiagnosticsPackage Class
Tango.FSE.Common.Diagnostics Namespace


DiagnosticsPackage Methods

The DiagnosticsPackage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDigitalInterfaceState | Gets the state of the digital interface.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHeaterState | Gets the state of the specified heater.
Public method | GetMonitorArray | Gets the data array from a protobuf repeated monitor by the specified TechMonitors enumeration.
Public method | GetMonitorLastValue | Gets the last data point of a repeated field monitor by the specified TechMonitors enumeration.
Public method | GetMonitorMatrix | Gets the data matrix from a protobuf repeated field of DoubleArray.
Public method | GetMonitorObject | Gets the monitor value by the specified TechMonitors enumeration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValveState | Gets the state of the specified valve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiagnosticsPackage Class
Tango.FSE.Common.Diagnostics Namespace


DiagnosticsPackage.GetDigitalInterfaceState Method

DiagnosticsPackageGetDigitalInterfaceState Method

Gets the state of the digital interface.

Namespace: Tango.FSE.Common.Diagnostics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DigitalInterfaceState GetDigitalInterfaceState(
    TechIos interface
)

Parameters

interface
Type: TechIos
The interface.

Return Value

Type: DigitalInterfaceState
Digital interface state object.
See Also

Reference

DiagnosticsPackage Class
Tango.FSE.Common.Diagnostics Namespace


DiagnosticsPackage.GetHeaterState Method

DiagnosticsPackageGetHeaterState Method

Gets the state of the specified heater.

Namespace: Tango.FSE.Common.Diagnostics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public HeaterState GetHeaterState(
    TechHeaters heater
)

Parameters

heater
Type: TechHeaters
The heater.

Return Value

Type: HeaterState
Heater state object.
See Also

Reference

DiagnosticsPackage Class
Tango.FSE.Common.Diagnostics Namespace


DiagnosticsPackage.GetMonitorArray Method

DiagnosticsPackageGetMonitorArray Method

Gets the data array from a protobuf repeated monitor by the specified TechMonitors enumeration.

Namespace: Tango.FSE.Common.Diagnostics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<double> GetMonitorArray(
    TechMonitors monitor
)

Parameters

monitor
Type: TechMonitors
The monitor enumeration.

Return Value

Type: ListDouble
List of double values representing the monitor data points.
See Also

Reference

DiagnosticsPackage Class
Tango.FSE.Common.Diagnostics Namespace


DiagnosticsPackage.GetMonitorLastValue Method

DiagnosticsPackageGetMonitorLastValue Method

Gets the last data point of a repeated field monitor by the specified TechMonitors enumeration.

Namespace: Tango.FSE.Common.Diagnostics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public double GetMonitorLastValue(
    TechMonitors monitor
)

Parameters

monitor
Type: TechMonitors
The monitor enumeration.

Return Value

Type: Double
Last value in the array.
See Also

Reference

DiagnosticsPackage Class
Tango.FSE.Common.Diagnostics Namespace


DiagnosticsPackage.GetMonitorMatrix Method

DiagnosticsPackageGetMonitorMatrix Method

Gets the data matrix from a protobuf repeated field of DoubleArray.

Namespace: Tango.FSE.Common.Diagnostics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public List<List<double>> GetMonitorMatrix(
    TechMonitors monitor
)

Parameters

monitor
Type: TechMonitors
The monitor enumeration.

Return Value

Type: ListListDouble
A matrix of double values.
See Also

Reference

DiagnosticsPackage Class
Tango.FSE.Common.Diagnostics Namespace


DiagnosticsPackage.GetMonitorObject Method

DiagnosticsPackageGetMonitorObject Method

Gets the monitor value by the specified TechMonitors enumeration.

Namespace: Tango.FSE.Common.Diagnostics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Object GetMonitorObject(
    TechMonitors monitor
)

Parameters

monitor
Type: TechMonitors
The monitor enumeration.

Return Value

Type: Object
The monitor object.
See Also

Reference

DiagnosticsPackage Class
Tango.FSE.Common.Diagnostics Namespace


DiagnosticsPackage.GetValveState Method

DiagnosticsPackageGetValveState Method

Gets the state of the specified valve.

Namespace: Tango.FSE.Common.Diagnostics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ValveState GetValveState(
    TechValves valve
)

Parameters

valve
Type: TechValves
The valve.

Return Value

Type: ValveState
Valve state object.
See Also

Reference

DiagnosticsPackage Class
Tango.FSE.Common.Diagnostics Namespace


Tango.FSE.Common.HotFolder Namespace

Classes
 | Class | Description
Public class | HotFolderItem |
Interfaces
 | Interface | Description
Public interface | IHotFolderService |
Enumerations
 | Enumeration | Description
Public enumeration | HotFolderItemStatus |


HotFolderItem Class

[Missing <summary> documentation for "T:Tango.FSE.Common.HotFolder.HotFolderItem"]

Inheritance Hierarchy
SystemObject
ExtendedObject
Tango.FSE.Common.HotFolderHotFolderItem

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class HotFolderItem : ExtendedObject

The HotFolderItem type exposes the following members.

Constructors
 | Name | Description
Public method | HotFolderItem | Initializes a new instance of the HotFolderItem class
Public method | HotFolderItem(String) | Initializes a new instance of the HotFolderItem class
Top
Properties
 | Name | Description
Public property | DateTime |
Public property | DesignMode | (Inherited from ExtendedObject.)
Public property | FilePath |
Public property | LogManager | (Inherited from ExtendedObject.)
Public property | Message |
Public property | Name |
Public property | Status |
Public property | TemporaryManager | (Inherited from ExtendedObject.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from ExtendedObject.)
Public event | RelayCommandsInvalidated | (Inherited from ExtendedObject.)
Top
See Also

Reference

Tango.FSE.Common.HotFolder Namespace


HotFolderItem Constructor

Overload List
 | Name | Description
Public method | HotFolderItem | Initializes a new instance of the HotFolderItem class
Public method | HotFolderItem(String) | Initializes a new instance of the HotFolderItem class
Top
See Also

Reference

HotFolderItem Class
Tango.FSE.Common.HotFolder Namespace


HotFolderItem Constructor

Initializes a new instance of the HotFolderItem class

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public HotFolderItem()
See Also

Reference

HotFolderItem Class
HotFolderItem Overload
Tango.FSE.Common.HotFolder Namespace


HotFolderItem Constructor (String)

Initializes a new instance of the HotFolderItem class

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public HotFolderItem(
    string file
)

Parameters

file
Type: SystemString

[Missing <param name="file"/> documentation for "M:Tango.FSE.Common.HotFolder.HotFolderItem.#ctor(System.String)"]

See Also

Reference

HotFolderItem Class
HotFolderItem Overload
Tango.FSE.Common.HotFolder Namespace


HotFolderItem Properties

The HotFolderItem type exposes the following members.

Properties
 | Name | Description
Public property | DateTime |
Public property | DesignMode | (Inherited from ExtendedObject.)
Public property | FilePath |
Public property | LogManager | (Inherited from ExtendedObject.)
Public property | Message |
Public property | Name |
Public property | Status |
Public property | TemporaryManager | (Inherited from ExtendedObject.)
Top
See Also

Reference

HotFolderItem Class
Tango.FSE.Common.HotFolder Namespace


HotFolderItem.DateTime Property

HotFolderItemDateTime Property

[Missing <summary> documentation for "P:Tango.FSE.Common.HotFolder.HotFolderItem.DateTime"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public DateTime DateTime { get; set; }

Property Value

Type: DateTime
See Also

Reference

HotFolderItem Class
Tango.FSE.Common.HotFolder Namespace


HotFolderItem.FilePath Property

HotFolderItemFilePath Property

[Missing <summary> documentation for "P:Tango.FSE.Common.HotFolder.HotFolderItem.FilePath"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string FilePath { get; set; }

Property Value

Type: String
See Also

Reference

HotFolderItem Class
Tango.FSE.Common.HotFolder Namespace


HotFolderItem.Message Property

HotFolderItemMessage Property

[Missing <summary> documentation for "P:Tango.FSE.Common.HotFolder.HotFolderItem.Message"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Message { get; set; }

Property Value

Type: String
See Also

Reference

HotFolderItem Class
Tango.FSE.Common.HotFolder Namespace


HotFolderItem.Name Property

HotFolderItemName Property

[Missing <summary> documentation for "P:Tango.FSE.Common.HotFolder.HotFolderItem.Name"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

HotFolderItem Class
Tango.FSE.Common.HotFolder Namespace


HotFolderItem.Status Property

HotFolderItemStatus Property

[Missing <summary> documentation for "P:Tango.FSE.Common.HotFolder.HotFolderItem.Status"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public HotFolderItemStatus Status { get; set; }

Property Value

Type: HotFolderItemStatus
See Also

Reference

HotFolderItem Class
Tango.FSE.Common.HotFolder Namespace


HotFolderItem Methods

The HotFolderItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HotFolderItem Class
Tango.FSE.Common.HotFolder Namespace


HotFolderItem Events

The HotFolderItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from ExtendedObject.)
Public event | RelayCommandsInvalidated | (Inherited from ExtendedObject.)
Top
See Also

Reference

HotFolderItem Class
Tango.FSE.Common.HotFolder Namespace


HotFolderItemStatus Enumeration

[Missing <summary> documentation for "T:Tango.FSE.Common.HotFolder.HotFolderItemStatus"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum HotFolderItemStatus
Members
Member name | Value | Description
Pending | 0 |
Uploading | 1 |
Completed | 2 |
Failed | 3 |
CompletedWithError | 4 |
See Also

Reference

Tango.FSE.Common.HotFolder Namespace


IHotFolderService Interface

[Missing <summary> documentation for "T:Tango.FSE.Common.HotFolder.IHotFolderService"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IHotFolderService

The IHotFolderService type exposes the following members.

Properties
 | Name | Description
Public property | Enabled |
Public property | HotFolderPath |
Public property | IsActive |
Public property | Items |
Top
Methods
 | Name | Description
Public method | RetryFailedItem |
Top
See Also

Reference

Tango.FSE.Common.HotFolder Namespace


IHotFolderService Properties

The IHotFolderService type exposes the following members.

Properties
 | Name | Description
Public property | Enabled |
Public property | HotFolderPath |
Public property | IsActive |
Public property | Items |
Top
See Also

Reference

IHotFolderService Interface
Tango.FSE.Common.HotFolder Namespace


IHotFolderService.Enabled Property

IHotFolderServiceEnabled Property

[Missing <summary> documentation for "P:Tango.FSE.Common.HotFolder.IHotFolderService.Enabled"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool Enabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

IHotFolderService Interface
Tango.FSE.Common.HotFolder Namespace


IHotFolderService.HotFolderPath Property

IHotFolderServiceHotFolderPath Property

[Missing <summary> documentation for "P:Tango.FSE.Common.HotFolder.IHotFolderService.HotFolderPath"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string HotFolderPath { get; set; }

Property Value

Type: String
See Also

Reference

IHotFolderService Interface
Tango.FSE.Common.HotFolder Namespace


IHotFolderService.IsActive Property

IHotFolderServiceIsActive Property

[Missing <summary> documentation for "P:Tango.FSE.Common.HotFolder.IHotFolderService.IsActive"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool IsActive { get; }

Property Value

Type: Boolean
See Also

Reference

IHotFolderService Interface
Tango.FSE.Common.HotFolder Namespace


IHotFolderService.Items Property

IHotFolderServiceItems Property

[Missing <summary> documentation for "P:Tango.FSE.Common.HotFolder.IHotFolderService.Items"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
SynchronizedObservableCollection<HotFolderItem> Items { get; }

Property Value

Type: SynchronizedObservableCollectionHotFolderItem
See Also

Reference

IHotFolderService Interface
Tango.FSE.Common.HotFolder Namespace


IHotFolderService Methods

The IHotFolderService type exposes the following members.

Methods
 | Name | Description
Public method | RetryFailedItem |
Top
See Also

Reference

IHotFolderService Interface
Tango.FSE.Common.HotFolder Namespace


IHotFolderService.RetryFailedItem Method

IHotFolderServiceRetryFailedItem Method

[Missing <summary> documentation for "M:Tango.FSE.Common.HotFolder.IHotFolderService.RetryFailedItem(Tango.FSE.Common.HotFolder.HotFolderItem)"]

Namespace: Tango.FSE.Common.HotFolder
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void RetryFailedItem(
    HotFolderItem item
)

Parameters

item
Type: Tango.FSE.Common.HotFolderHotFolderItem

[Missing <param name="item"/> documentation for "M:Tango.FSE.Common.HotFolder.IHotFolderService.RetryFailedItem(Tango.FSE.Common.HotFolder.HotFolderItem)"]

See Also

Reference

IHotFolderService Interface
Tango.FSE.Common.HotFolder Namespace


Tango.FSE.Common.RemoteActions Namespace

Interfaces
 | Interface | Description
Public interface | IRemoteActionsProvider |


IRemoteActionsProvider Interface

[Missing <summary> documentation for "T:Tango.FSE.Common.RemoteActions.IRemoteActionsProvider"]

Namespace: Tango.FSE.Common.RemoteActions
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IRemoteActionsProvider

The IRemoteActionsProvider type exposes the following members.

Methods
 | Name | Description
Public method | RestartApplication |
Public method | SimulateApplicationException |
Top
See Also

Reference

Tango.FSE.Common.RemoteActions Namespace


IRemoteActionsProvider Methods

The IRemoteActionsProvider type exposes the following members.

Methods
 | Name | Description
Public method | RestartApplication |
Public method | SimulateApplicationException |
Top
See Also

Reference

IRemoteActionsProvider Interface
Tango.FSE.Common.RemoteActions Namespace


IRemoteActionsProvider.RestartApplication Method

IRemoteActionsProviderRestartApplication Method

[Missing <summary> documentation for "M:Tango.FSE.Common.RemoteActions.IRemoteActionsProvider.RestartApplication"]

Namespace: Tango.FSE.Common.RemoteActions
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void RestartApplication()
See Also

Reference

IRemoteActionsProvider Interface
Tango.FSE.Common.RemoteActions Namespace


IRemoteActionsProvider.SimulateApplicationException Method

IRemoteActionsProviderSimulateApplicationException Method

[Missing <summary> documentation for "M:Tango.FSE.Common.RemoteActions.IRemoteActionsProvider.SimulateApplicationException(System.Boolean)"]

Namespace: Tango.FSE.Common.RemoteActions
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void SimulateApplicationException(
    bool causeCrash
)

Parameters

causeCrash
Type: SystemBoolean

[Missing <param name="causeCrash"/> documentation for "M:Tango.FSE.Common.RemoteActions.IRemoteActionsProvider.SimulateApplicationException(System.Boolean)"]

See Also

Reference

IRemoteActionsProvider Interface
Tango.FSE.Common.RemoteActions Namespace


Tango.FSE.Common.RemoteJobUpload Namespace

Interfaces
 | Interface | Description
Public interface | IRemoteJobUploadProvider | Represents a remote machine PPC job upload provider.


IRemoteJobUploadProvider Interface

Represents a remote machine PPC job upload provider.

Namespace: Tango.FSE.Common.RemoteJobUpload
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IRemoteJobUploadProvider

The IRemoteJobUploadProvider type exposes the following members.

Methods
 | Name | Description
Public method | UploadJob | Uploads the specified job file to the remote connected machine.
Top
See Also

Reference

Tango.FSE.Common.RemoteJobUpload Namespace


IRemoteJobUploadProvider Methods

The IRemoteJobUploadProvider type exposes the following members.

Methods
 | Name | Description
Public method | UploadJob | Uploads the specified job file to the remote connected machine.
Top
See Also

Reference

IRemoteJobUploadProvider Interface
Tango.FSE.Common.RemoteJobUpload Namespace


IRemoteJobUploadProvider.UploadJob Method

IRemoteJobUploadProviderUploadJob Method

Uploads the specified job file to the remote connected machine.

Namespace: Tango.FSE.Common.RemoteJobUpload
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task UploadJob(
    string filePath,
    RemoteJobUploadType jobType,
    string name = null
)

Parameters

filePath
Type: SystemString
The job file path.
jobType
Type: Tango.PPC.Shared.RemoteJobUploadRemoteJobUploadType
Remote job type.
name (Optional)
Type: SystemString
Optional job name

Return Value

Type: Task

[Missing <returns> documentation for "M:Tango.FSE.Common.RemoteJobUpload.IRemoteJobUploadProvider.UploadJob(System.String,Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadType,System.String)"]

See Also

Reference

IRemoteJobUploadProvider Interface
Tango.FSE.Common.RemoteJobUpload Namespace


Tango.FSE.Common.SQL Namespace

Classes
Class | Description
RemoteSqlCommand | Represents a SQL command that can be executed by a IRemoteSqlProvider.
RemoteSqlCommandResult | Represents a RemoteSqlCommand result.
Interfaces
Interface | Description
IRemoteSqlProvider | Represents a remote SQL provider. Can be used to execute commands against the remote machine's database and the global twine's database.
Enumerations
Enumeration | Description
RemoteSqlCommandMode | Represents an SQL command execution mode.


IRemoteSqlProvider Interface

Represents a remote SQL provider. Can be used to execute commands against the remote machine's database and the global twine's database.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IRemoteSqlProvider

The IRemoteSqlProvider type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteSqlCommand | Executes the SQL command.
Public method | ExecuteSqlCommandAsync | Executes the SQL command asynchronously.
Top
Examples

The following example demonstrates how to set the connected machine's demo state and query for the connected machine's jobs.

Remote SQL
Copy
//Additional name spaces that are required for working with remote SQL.
using Tango.FSE.Common.SQL;
using Tango.PPC.Shared.SQL;

public class Program
{
    public void OnExecute(IProcedureContext context)
    {

        //Get the remote SQL provider from the Tango IOC container.
        IRemoteSqlProvider sql = context.GetService<IRemoteSqlProvider>();

        //Create the SQL command and direct it to affect both the local machine's database and the global Twine's database.
        RemoteSqlCommand command = new RemoteSqlCommand();
        command.SQL = "UPDATE MACHINES SET IS_DEMO = 0 WHERE SERIAL_NUMBER = '" + context.ConnectedMachine.SerialNumber + "'";
        command.Mode = RemoteSqlCommandMode.Both;

        //Execute the command...
        RemoteSqlCommandResult result = sql.ExecuteSqlCommand(command);

        context.WriteLine("Command executed.");
        context.WriteLine("Local Affected Rows " + result.LocalAffectedRecords);
        context.WriteLine("Global Affected Rows " + result.GlobalAffectedRecords);

        context.WriteLine("");

        //Query the machine's database for all the jobs names and length.
        command.SQL = "SELECT NAME,LAST_RUN FROM JOBS";
        command.Mode = RemoteSqlCommandMode.Local;

        result = sql.ExecuteSqlCommand(command);

        //Check for errors.
        if (!result.HasLocalError)
        {
            //Write the formatted results set to the console.
            context.WriteLine(result.LocalDatSet.ToTableString());
            context.WriteLine("");

            //Iterate over the data set rows and get values.
            foreach (RemoteSqlRow row in result.LocalDatSet.Rows)
            {
                String name = row.Get<String>("NAME");
                String lastRun = row.Get<String>("LAST_RUN");

                context.WriteLine(String.Format("NAME {0}, LAST_RUN {1}", name, lastRun));
            }
        }
        else
        {
            //Write the error to console.
            context.WriteLine(result.LocalError);
        }
    }
}
See Also

Reference

Tango.FSE.Common.SQL Namespace


IRemoteSqlProvider Methods

The IRemoteSqlProvider type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteSqlCommand | Executes the SQL command.
Public method | ExecuteSqlCommandAsync | Executes the SQL command asynchronously.
Top
See Also

Reference

IRemoteSqlProvider Interface
Tango.FSE.Common.SQL Namespace


IRemoteSqlProvider.ExecuteSqlCommand Method

IRemoteSqlProviderExecuteSqlCommand Method

Executes the SQL command.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
RemoteSqlCommandResult ExecuteSqlCommand(
    RemoteSqlCommand command
)

Parameters

command
Type: Tango.FSE.Common.SQLRemoteSqlCommand
The command.

Return Value

Type: RemoteSqlCommandResult
Remote command result.
See Also

Reference

IRemoteSqlProvider Interface
Tango.FSE.Common.SQL Namespace


IRemoteSqlProvider.ExecuteSqlCommandAsync Method

IRemoteSqlProviderExecuteSqlCommandAsync Method

Executes the SQL command asynchronously.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task<RemoteSqlCommandResult> ExecuteSqlCommandAsync(
    RemoteSqlCommand command
)

Parameters

command
Type: Tango.FSE.Common.SQLRemoteSqlCommand
The command.

Return Value

Type: TaskRemoteSqlCommandResult
Remote command result.
See Also

Reference

IRemoteSqlProvider Interface
Tango.FSE.Common.SQL Namespace


RemoteSqlCommand Class

Represents a SQL command that can be executed by a IRemoteSqlProvider.
Inheritance Hierarchy
SystemObject
Tango.FSE.Common.SQLRemoteSqlCommand

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class RemoteSqlCommand

The RemoteSqlCommand type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteSqlCommand | Initializes a new instance of the RemoteSqlCommand class.
Top
Properties
 | Name | Description
Public property | Mode | Gets or sets the command execution mode.
Public property | SQL | Gets or sets the SQL query.
Public property | Timeout | Gets or sets the command timeout.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples

The following example demonstrates how to set the connected machine's demo state and query for the connected machine's jobs.

Remote SQL
Copy
//Additional name spaces that are required for working with remote SQL.
using Tango.FSE.Common.SQL;
using Tango.PPC.Shared.SQL;

public class Program
{
    public void OnExecute(IProcedureContext context)
    {

        //Get the remote SQL provider from the Tango IOC container.
        IRemoteSqlProvider sql = context.GetService<IRemoteSqlProvider>();

        //Create the SQL command and direct it to affect both the local machine's database and the global Twine's database.
        RemoteSqlCommand command = new RemoteSqlCommand();
        command.SQL = "UPDATE MACHINES SET IS_DEMO = 0 WHERE SERIAL_NUMBER = '" + context.ConnectedMachine.SerialNumber + "'";
        command.Mode = RemoteSqlCommandMode.Both;

        //Execute the command...
        RemoteSqlCommandResult result = sql.ExecuteSqlCommand(command);

        context.WriteLine("Command executed.");
        context.WriteLine("Local Affected Rows " + result.LocalAffectedRecords);
        context.WriteLine("Global Affected Rows " + result.GlobalAffectedRecords);

        context.WriteLine("");

        //Query the machine's database for all the jobs names and length.
        command.SQL = "SELECT NAME,LAST_RUN FROM JOBS";
        command.Mode = RemoteSqlCommandMode.Local;

        result = sql.ExecuteSqlCommand(command);

        //Check for errors.
        if (!result.HasLocalError)
        {
            //Write the formatted results set to the console.
            context.WriteLine(result.LocalDatSet.ToTableString());
            context.WriteLine("");

            //Iterate over the data set rows and get values.
            foreach (RemoteSqlRow row in result.LocalDatSet.Rows)
            {
                String name = row.Get<String>("NAME");
                String lastRun = row.Get<String>("LAST_RUN");

                context.WriteLine(String.Format("NAME {0}, LAST_RUN {1}", name, lastRun));
            }
        }
        else
        {
            //Write the error to console.
            context.WriteLine(result.LocalError);
        }
    }
}
See Also

Reference

Tango.FSE.Common.SQL Namespace


RemoteSqlCommand Constructor

Initializes a new instance of the RemoteSqlCommand class.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public RemoteSqlCommand()
See Also

Reference

RemoteSqlCommand Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommand Properties

The RemoteSqlCommand type exposes the following members.

Properties
 | Name | Description
Public property | Mode | Gets or sets the command execution mode.
Public property | SQL | Gets or sets the SQL query.
Public property | Timeout | Gets or sets the command timeout.
Top
See Also

Reference

RemoteSqlCommand Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommand.Mode Property

RemoteSqlCommandMode Property

Gets or sets the command execution mode.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public RemoteSqlCommandMode Mode { get; set; }

Property Value

Type: RemoteSqlCommandMode
See Also

Reference

RemoteSqlCommand Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommand.SQL Property

RemoteSqlCommandSQL Property

Gets or sets the SQL query.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string SQL { get; set; }

Property Value

Type: String
See Also

Reference

RemoteSqlCommand Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommand.Timeout Property

RemoteSqlCommandTimeout Property

Gets or sets the command timeout.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Timeout { get; set; }

Property Value

Type: Int32
See Also

Reference

RemoteSqlCommand Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommand Methods

The RemoteSqlCommand type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteSqlCommand Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandMode Enumeration

Represents an SQL command execution mode.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum RemoteSqlCommandMode
Members
Member name | Value | Description
Local | 0 | Executes the command against the connected local database.
Global | 1 | Executes the command against the global Twine's database.
Both | 2 | Executes the command against the connected machine and the global databases.
Examples

The following example demonstrates how to set the connected machine's demo state and query for the connected machine's jobs.

Remote SQL
Copy
//Additional name spaces that are required for working with remote SQL.
using Tango.FSE.Common.SQL;
using Tango.PPC.Shared.SQL;

public class Program
{
    public void OnExecute(IProcedureContext context)
    {

        //Get the remote SQL provider from the Tango IOC container.
        IRemoteSqlProvider sql = context.GetService<IRemoteSqlProvider>();

        //Create the SQL command and direct it to affect both the local machine's database and the global Twine's database.
        RemoteSqlCommand command = new RemoteSqlCommand();
        command.SQL = "UPDATE MACHINES SET IS_DEMO = 0 WHERE SERIAL_NUMBER = '" + context.ConnectedMachine.SerialNumber + "'";
        command.Mode = RemoteSqlCommandMode.Both;

        //Execute the command...
        RemoteSqlCommandResult result = sql.ExecuteSqlCommand(command);

        context.WriteLine("Command executed.");
        context.WriteLine("Local Affected Rows " + result.LocalAffectedRecords);
        context.WriteLine("Global Affected Rows " + result.GlobalAffectedRecords);

        context.WriteLine("");

        //Query the machine's database for all the jobs names and length.
        command.SQL = "SELECT NAME,LAST_RUN FROM JOBS";
        command.Mode = RemoteSqlCommandMode.Local;

        result = sql.ExecuteSqlCommand(command);

        //Check for errors.
        if (!result.HasLocalError)
        {
            //Write the formatted results set to the console.
            context.WriteLine(result.LocalDatSet.ToTableString());
            context.WriteLine("");

            //Iterate over the data set rows and get values.
            foreach (RemoteSqlRow row in result.LocalDatSet.Rows)
            {
                String name = row.Get<String>("NAME");
                String lastRun = row.Get<String>("LAST_RUN");

                context.WriteLine(String.Format("NAME {0}, LAST_RUN {1}", name, lastRun));
            }
        }
        else
        {
            //Write the error to console.
            context.WriteLine(result.LocalError);
        }
    }
}
See Also

Reference

Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult Class

Represents a RemoteSqlCommand result.
Inheritance Hierarchy
SystemObject
Tango.FSE.Common.SQLRemoteSqlCommandResult

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class RemoteSqlCommandResult

The RemoteSqlCommandResult type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteSqlCommandResult | Initializes a new instance of the RemoteSqlCommandResult class.
Top
Properties
 | Name | Description
Public property | GlobalAffectedRecords | Gets or sets the global database affected records.
Public property | GlobalDataSet | Gets or sets the data set retrieved from the global database.
Public property | GlobalError | Gets or sets the error encountered by the query when it was executed against the global database. Relevant only if HasGlobalError equals true.
Public property | HasGlobalError | Gets or sets a value indicating whether the query against the global database has encountered an error.
Public property | HasLocalError | Gets or sets a value indicating whether the query against the connected machine's database has encountered an error.
Public property | LocalAffectedRecords | Gets or sets the connected machine's database affected records.
Public property | LocalDatSet | Gets or sets the data set retrieved from the connected machine's database.
Public property | LocalError | Gets or sets the error encountered by the query when it was executed against the connected machine's database. Relevant only if HasLocalError equals true.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples

The following example demonstrates how to set the connected machine's demo state and query for the connected machine's jobs.

Remote SQL
Copy
//Additional name spaces that are required for working with remote SQL.
using Tango.FSE.Common.SQL;
using Tango.PPC.Shared.SQL;

public class Program
{
    public void OnExecute(IProcedureContext context)
    {

        //Get the remote SQL provider from the Tango IOC container.
        IRemoteSqlProvider sql = context.GetService<IRemoteSqlProvider>();

        //Create the SQL command and direct it to affect both the local machine's database and the global Twine's database.
        RemoteSqlCommand command = new RemoteSqlCommand();
        command.SQL = "UPDATE MACHINES SET IS_DEMO = 0 WHERE SERIAL_NUMBER = '" + context.ConnectedMachine.SerialNumber + "'";
        command.Mode = RemoteSqlCommandMode.Both;

        //Execute the command...
        RemoteSqlCommandResult result = sql.ExecuteSqlCommand(command);

        context.WriteLine("Command executed.");
        context.WriteLine("Local Affected Rows " + result.LocalAffectedRecords);
        context.WriteLine("Global Affected Rows " + result.GlobalAffectedRecords);

        context.WriteLine("");

        //Query the machine's database for all the jobs names and length.
        command.SQL = "SELECT NAME,LAST_RUN FROM JOBS";
        command.Mode = RemoteSqlCommandMode.Local;

        result = sql.ExecuteSqlCommand(command);

        //Check for errors.
        if (!result.HasLocalError)
        {
            //Write the formatted results set to the console.
            context.WriteLine(result.LocalDatSet.ToTableString());
            context.WriteLine("");

            //Iterate over the data set rows and get values.
            foreach (RemoteSqlRow row in result.LocalDatSet.Rows)
            {
                String name = row.Get<String>("NAME");
                String lastRun = row.Get<String>("LAST_RUN");

                context.WriteLine(String.Format("NAME {0}, LAST_RUN {1}", name, lastRun));
            }
        }
        else
        {
            //Write the error to console.
            context.WriteLine(result.LocalError);
        }
    }
}
See Also

Reference

Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult Constructor

Initializes a new instance of the RemoteSqlCommandResult class.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public RemoteSqlCommandResult()
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult Properties

The RemoteSqlCommandResult type exposes the following members.

Properties
 | Name | Description
Public property | GlobalAffectedRecords | Gets or sets the global database affected records.
Public property | GlobalDataSet | Gets or sets the data set retrieved from the global database.
Public property | GlobalError | Gets or sets the error encountered by the query when it was executed against the global database. Relevant only if HasGlobalError equals true.
Public property | HasGlobalError | Gets or sets a value indicating whether the query against the global database has encountered an error.
Public property | HasLocalError | Gets or sets a value indicating whether the query against the connected machine's database has encountered an error.
Public property | LocalAffectedRecords | Gets or sets the connected machine's database affected records.
Public property | LocalDatSet | Gets or sets the data set retrieved from the connected machine's database.
Public property | LocalError | Gets or sets the error encountered by the query when it was executed against the connected machine's database. Relevant only if HasLocalError equals true.
Top
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult.GlobalAffectedRecords Property

RemoteSqlCommandResultGlobalAffectedRecords Property

Gets or sets the global database affected records.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int GlobalAffectedRecords { get; set; }

Property Value

Type: Int32
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult.GlobalDataSet Property

RemoteSqlCommandResultGlobalDataSet Property

Gets or sets the data set retrieved from the global database.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public RemoteSqlDataSet GlobalDataSet { get; set; }

Property Value

Type: RemoteSqlDataSet
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult.GlobalError Property

RemoteSqlCommandResultGlobalError Property

Gets or sets the error encountered by the query when it was executed against the global database. Relevant only if HasGlobalError equals true.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string GlobalError { get; set; }

Property Value

Type: String
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult.HasGlobalError Property

RemoteSqlCommandResultHasGlobalError Property

Gets or sets a value indicating whether the query against the global database has encountered an error.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool HasGlobalError { get; set; }

Property Value

Type: Boolean
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult.HasLocalError Property

RemoteSqlCommandResultHasLocalError Property

Gets or sets a value indicating whether the query against the connected machine's database has encountered an error.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool HasLocalError { get; set; }

Property Value

Type: Boolean
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult.LocalAffectedRecords Property

RemoteSqlCommandResultLocalAffectedRecords Property

Gets or sets the connected machine's database affected records.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int LocalAffectedRecords { get; set; }

Property Value

Type: Int32
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult.LocalDatSet Property

RemoteSqlCommandResultLocalDatSet Property

Gets or sets the data set retrieved from the connected machine's database.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public RemoteSqlDataSet LocalDatSet { get; set; }

Property Value

Type: RemoteSqlDataSet
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult.LocalError Property

RemoteSqlCommandResultLocalError Property

Gets or sets the error encountered by the query when it was executed against the connected machine's database. Relevant only if HasLocalError equals true.

Namespace: Tango.FSE.Common.SQL
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string LocalError { get; set; }

Property Value

Type: String
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


RemoteSqlCommandResult Methods

The RemoteSqlCommandResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteSqlCommandResult Class
Tango.FSE.Common.SQL Namespace


Tango.FSE.Common.Statistics Namespace

Classes
 | Class | Description
Public class | JobRunReceivedEventArgs |
Public class | StatisticsModel |
Interfaces
 | Interface | Description
Public interface | IStatisticsProvider |


IStatisticsProvider Interface

[Missing <summary> documentation for "T:Tango.FSE.Common.Statistics.IStatisticsProvider"]

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IStatisticsProvider

The IStatisticsProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetJobRunExtendedInfo |
Public method | GetRequiredFiltersData |
Public method | GetStatistics |
Top
Events
 | Name | Description
Public event | JobRunReceived |
Top
See Also

Reference

Tango.FSE.Common.Statistics Namespace


IStatisticsProvider Methods

The IStatisticsProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetJobRunExtendedInfo |
Public method | GetRequiredFiltersData |
Public method | GetStatistics |
Top
See Also

Reference

IStatisticsProvider Interface
Tango.FSE.Common.Statistics Namespace


IStatisticsProvider.GetJobRunExtendedInfo Method

IStatisticsProviderGetJobRunExtendedInfo Method

[Missing <summary> documentation for "M:Tango.FSE.Common.Statistics.IStatisticsProvider.GetJobRunExtendedInfo(System.Int32)"]

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task<JobRunExtendedInfo> GetJobRunExtendedInfo(
    int jobRunID
)

Parameters

jobRunID
Type: SystemInt32

[Missing <param name="jobRunID"/> documentation for "M:Tango.FSE.Common.Statistics.IStatisticsProvider.GetJobRunExtendedInfo(System.Int32)"]

Return Value

Type: TaskJobRunExtendedInfo

[Missing <returns> documentation for "M:Tango.FSE.Common.Statistics.IStatisticsProvider.GetJobRunExtendedInfo(System.Int32)"]

See Also

Reference

IStatisticsProvider Interface
Tango.FSE.Common.Statistics Namespace


IStatisticsProvider.GetRequiredFiltersData Method

IStatisticsProviderGetRequiredFiltersData Method

[Missing <summary> documentation for "M:Tango.FSE.Common.Statistics.IStatisticsProvider.GetRequiredFiltersData"]

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task<RequiredFiltersData> GetRequiredFiltersData()

Return Value

Type: TaskRequiredFiltersData

[Missing <returns> documentation for "M:Tango.FSE.Common.Statistics.IStatisticsProvider.GetRequiredFiltersData"]

See Also

Reference

IStatisticsProvider Interface
Tango.FSE.Common.Statistics Namespace


IStatisticsProvider.GetStatistics Method

IStatisticsProviderGetStatistics Method

[Missing <summary> documentation for "M:Tango.FSE.Common.Statistics.IStatisticsProvider.GetStatistics(Tango.PPC.Shared.Statistics.Filters)"]

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task<StatisticsModel> GetStatistics(
    Filters filters
)

Parameters

filters
Type: Tango.PPC.Shared.StatisticsFilters

[Missing <param name="filters"/> documentation for "M:Tango.FSE.Common.Statistics.IStatisticsProvider.GetStatistics(Tango.PPC.Shared.Statistics.Filters)"]

Return Value

Type: TaskStatisticsModel

[Missing <returns> documentation for "M:Tango.FSE.Common.Statistics.IStatisticsProvider.GetStatistics(Tango.PPC.Shared.Statistics.Filters)"]

See Also

Reference

IStatisticsProvider Interface
Tango.FSE.Common.Statistics Namespace


IStatisticsProvider Events

The IStatisticsProvider type exposes the following members.

Events
 | Name | Description
Public event | JobRunReceived |
Top
See Also

Reference

IStatisticsProvider Interface
Tango.FSE.Common.Statistics Namespace


IStatisticsProvider.JobRunReceived Event

IStatisticsProviderJobRunReceived Event

[Missing <summary> documentation for "E:Tango.FSE.Common.Statistics.IStatisticsProvider.JobRunReceived"]

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
event EventHandler<JobRunReceivedEventArgs> JobRunReceived

Value

Type: SystemEventHandlerJobRunReceivedEventArgs
See Also

Reference

IStatisticsProvider Interface
Tango.FSE.Common.Statistics Namespace


JobRunReceivedEventArgs Class

[Missing <summary> documentation for "T:Tango.FSE.Common.Statistics.JobRunReceivedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
Tango.FSE.Common.StatisticsJobRunReceivedEventArgs

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class JobRunReceivedEventArgs : EventArgs

The JobRunReceivedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | JobRunReceivedEventArgs | Initializes a new instance of the JobRunReceivedEventArgs class
Top
Properties
 | Name | Description
Public property | JobRunComposition |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.FSE.Common.Statistics Namespace


JobRunReceivedEventArgs Constructor

Initializes a new instance of the JobRunReceivedEventArgs class

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public JobRunReceivedEventArgs()
See Also

Reference

JobRunReceivedEventArgs Class
Tango.FSE.Common.Statistics Namespace


JobRunReceivedEventArgs Properties

The JobRunReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | JobRunComposition |
Top
See Also

Reference

JobRunReceivedEventArgs Class
Tango.FSE.Common.Statistics Namespace


JobRunReceivedEventArgs.JobRunComposition Property

JobRunReceivedEventArgsJobRunComposition Property

[Missing <summary> documentation for "P:Tango.FSE.Common.Statistics.JobRunReceivedEventArgs.JobRunComposition"]

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public JobRunComposition JobRunComposition { get; set; }

Property Value

Type: JobRunComposition
See Also

Reference

JobRunReceivedEventArgs Class
Tango.FSE.Common.Statistics Namespace


JobRunReceivedEventArgs Methods

The JobRunReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobRunReceivedEventArgs Class
Tango.FSE.Common.Statistics Namespace


StatisticsModel Class

[Missing <summary> documentation for "T:Tango.FSE.Common.Statistics.StatisticsModel"]

Inheritance Hierarchy
SystemObject
Tango.FSE.Common.StatisticsStatisticsModel

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class StatisticsModel

The StatisticsModel type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsModel | Initializes a new instance of the StatisticsModel class
Top
Properties
 | Name | Description
Public property | StatisticsResult |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.FSE.Common.Statistics Namespace


StatisticsModel Constructor

Initializes a new instance of the StatisticsModel class

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public StatisticsModel()
See Also

Reference

StatisticsModel Class
Tango.FSE.Common.Statistics Namespace


StatisticsModel Properties

The StatisticsModel type exposes the following members.

Properties
 | Name | Description
Public property | StatisticsResult |
Top
See Also

Reference

StatisticsModel Class
Tango.FSE.Common.Statistics Namespace


StatisticsModel.StatisticsResult Property

StatisticsModelStatisticsResult Property

[Missing <summary> documentation for "P:Tango.FSE.Common.Statistics.StatisticsModel.StatisticsResult"]

Namespace: Tango.FSE.Common.Statistics
Assembly: Tango.FSE.Common (in Tango.FSE.Common.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public StatisticsResult StatisticsResult { get; set; }

Property Value

Type: StatisticsResult
See Also

Reference

StatisticsModel Class
Tango.FSE.Common.Statistics Namespace


StatisticsModel Methods

The StatisticsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StatisticsModel Class
Tango.FSE.Common.Statistics Namespace


Tango.FSE.Procedures Namespace

Contains a collection of interfaces and classes for the main procedures API.
Classes
 | Class | Description
Public class | Result |
Public class | UserInput |
Interfaces
 | Interface | Description
Public interface | IDialogController |
Public interface | IProcedureContext |
Enumerations
 | Enumeration | Description
Public enumeration | ArrayParsingStyle |
Public enumeration | ResultType |


ArrayParsingStyle Enumeration

[Missing <summary> documentation for "T:Tango.FSE.Procedures.ArrayParsingStyle"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum ArrayParsingStyle
Members
Member name | Value | Description
Comma | 0 |
SquareBrackets | 1 |
See Also

Reference

Tango.FSE.Procedures Namespace


IDialogController Interface

[Missing <summary> documentation for "T:Tango.FSE.Procedures.IDialogController"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IDialogController

The IDialogController type exposes the following members.

Methods
 | Name | Description
Public method | Close |
Public method | FindControlT |
Public method | Show |
Top
See Also

Reference

Tango.FSE.Procedures Namespace


IDialogController Methods

The IDialogController type exposes the following members.

Methods
 | Name | Description
Public method | Close |
Public method | FindControlT |
Public method | Show |
Top
See Also

Reference

IDialogController Interface
Tango.FSE.Procedures Namespace


IDialogController.Close Method

IDialogControllerClose Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IDialogController.Close"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Close()
See Also

Reference

IDialogController Interface
Tango.FSE.Procedures Namespace


IDialogController.FindControl(T) Method

IDialogControllerFindControlT Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IDialogController.FindControl``1(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
T FindControl<T>(
    string name
)
where T : DependencyObject

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.IDialogController.FindControl``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IDialogController.FindControl``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IDialogController.FindControl``1(System.String)"]

See Also

Reference

IDialogController Interface
Tango.FSE.Procedures Namespace


IDialogController.Show Method

IDialogControllerShow Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IDialogController.Show"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Show()
See Also

Reference

IDialogController Interface
Tango.FSE.Procedures Namespace


IProcedureContext Interface

[Missing <summary> documentation for "T:Tango.FSE.Procedures.IProcedureContext"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IProcedureContext : IContext

The IProcedureContext type exposes the following members.

Properties
 | Name | Description
Public property | ConnectedMachine |
Public property | ConnectionType |
Public property | IsConnected |
Public property | OnExitAction |
Top
Methods
 | Name | Description
Public method | AddBitmapResult |
Public method | AddGraphResult |
Public method | AddResult(Result) |
Public method | AddResult(ResultType, String, Object) |
Public method | AppendToFile |
Public method | Clear |
Public method | ClearResults |
Public method | CreateBitmap |
Public method | Fail |
Public method | GetDiagnosticsPackage |
Public method | GetDrawingContext |
Public method | GetFileBytes |
Public method | GetFileText |
Public method | GetInput(String) |
Public method | GetInputT(String) |
Public method | GetInputArrayT |
Public method | GetRemoteDataStoreManager |
Public method | GetResourceBytes |
Public method | GetResourceString |
Public method | GetServiceT |
Public method | GetVariable(String) |
Public method | GetVariableT(String) |
Public method | GetVariableArrayT |
Public method | LoadDialog |
Public method | LoadDialogAsWindow |
Public method | OpenResource |
Public method | ReadCsvT(Byte) |
Public method | ReadCsvT(String) |
Public method | RemoveResult |
Public method | RequestFileOpen |
Public method | RequestFileSave |
Public method | RequestFolderSelect |
Public method | RequestUserInputForT(String, String) |
Public method | RequestUserInputForT(T, String, String) |
Public method | RunAsync |
Public method | Send(IMessage, NullableInt32) |
Public method | Send(String, Object) |
Public method | Send(String, NullableTimeSpan, Object) |
Public method | SendT(IMessage, NullableInt32) |
Public method | SendT(String, Object) |
Public method | SendT(String, NullableTimeSpan, Object) |
Public method | SendContinuousT(IMessage, ActionT, NullableInt32) |
Public method | SendContinuousT(String, ActionT, Object) |
Public method | SendContinuousT(String, ActionT, NullableTimeSpan, Object) |
Public method | ShowError |
Public method | ShowErrorRemote |
Public method | ShowInfo |
Public method | ShowInfoRemote |
Public method | ShowQuestion |
Public method | ShowQuestionRemote |
Public method | ShowWarning |
Public method | ShowWarningQuestion |
Public method | ShowWarningRemote |
Public method | Sleep |
Public method | UpdateProgress |
Public method | Write |
Public method | WriteCsvT |
Public method | WriteHex |
Public method | WriteLine |
Public method | WriteLine(Object) |
Public method | WriteLineArray |
Public method | WriteLineHex |
Public method | WriteToFile |
Top
See Also

Reference

Tango.FSE.Procedures Namespace


IProcedureContext Properties

The IProcedureContext type exposes the following members.

Properties
 | Name | Description
Public property | ConnectedMachine |
Public property | ConnectionType |
Public property | IsConnected |
Public property | OnExitAction |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ConnectedMachine Property

IProcedureContextConnectedMachine Property

[Missing <summary> documentation for "P:Tango.FSE.Procedures.IProcedureContext.ConnectedMachine"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Machine ConnectedMachine { get; }

Property Value

Type: Machine
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ConnectionType Property

IProcedureContextConnectionType Property

[Missing <summary> documentation for "P:Tango.FSE.Procedures.IProcedureContext.ConnectionType"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
MachineConnectionTypes ConnectionType { get; }

Property Value

Type: MachineConnectionTypes
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.IsConnected Property

IProcedureContextIsConnected Property

[Missing <summary> documentation for "P:Tango.FSE.Procedures.IProcedureContext.IsConnected"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool IsConnected { get; }

Property Value

Type: Boolean
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.OnExitAction Property

IProcedureContextOnExitAction Property

[Missing <summary> documentation for "P:Tango.FSE.Procedures.IProcedureContext.OnExitAction"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Action<IProcedureContext> OnExitAction { get; set; }

Property Value

Type: ActionIProcedureContext
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext Methods

The IProcedureContext type exposes the following members.

Methods
 | Name | Description
Public method | AddBitmapResult |
Public method | AddGraphResult |
Public method | AddResult(Result) |
Public method | AddResult(ResultType, String, Object) |
Public method | AppendToFile |
Public method | Clear |
Public method | ClearResults |
Public method | CreateBitmap |
Public method | Fail |
Public method | GetDiagnosticsPackage |
Public method | GetDrawingContext |
Public method | GetFileBytes |
Public method | GetFileText |
Public method | GetInput(String) |
Public method | GetInputT(String) |
Public method | GetInputArrayT |
Public method | GetRemoteDataStoreManager |
Public method | GetResourceBytes |
Public method | GetResourceString |
Public method | GetServiceT |
Public method | GetVariable(String) |
Public method | GetVariableT(String) |
Public method | GetVariableArrayT |
Public method | LoadDialog |
Public method | LoadDialogAsWindow |
Public method | OpenResource |
Public method | ReadCsvT(Byte) |
Public method | ReadCsvT(String) |
Public method | RemoveResult |
Public method | RequestFileOpen |
Public method | RequestFileSave |
Public method | RequestFolderSelect |
Public method | RequestUserInputForT(String, String) |
Public method | RequestUserInputForT(T, String, String) |
Public method | RunAsync |
Public method | Send(IMessage, NullableInt32) |
Public method | Send(String, Object) |
Public method | Send(String, NullableTimeSpan, Object) |
Public method | SendT(IMessage, NullableInt32) |
Public method | SendT(String, Object) |
Public method | SendT(String, NullableTimeSpan, Object) |
Public method | SendContinuousT(IMessage, ActionT, NullableInt32) |
Public method | SendContinuousT(String, ActionT, Object) |
Public method | SendContinuousT(String, ActionT, NullableTimeSpan, Object) |
Public method | ShowError |
Public method | ShowErrorRemote |
Public method | ShowInfo |
Public method | ShowInfoRemote |
Public method | ShowQuestion |
Public method | ShowQuestionRemote |
Public method | ShowWarning |
Public method | ShowWarningQuestion |
Public method | ShowWarningRemote |
Public method | Sleep |
Public method | UpdateProgress |
Public method | Write |
Public method | WriteCsvT |
Public method | WriteHex |
Public method | WriteLine |
Public method | WriteLine(Object) |
Public method | WriteLineArray |
Public method | WriteLineHex |
Public method | WriteToFile |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.AddBitmapResult Method

IProcedureContextAddBitmapResult Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddBitmapResult(Tango.FSE.Procedures.ResultType,System.String,System.Drawing.Bitmap)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Result AddBitmapResult(
    ResultType type,
    string name,
    Bitmap bitmap
)

Parameters

type
Type: Tango.FSE.ProceduresResultType

[Missing <param name="type"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddBitmapResult(Tango.FSE.Procedures.ResultType,System.String,System.Drawing.Bitmap)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddBitmapResult(Tango.FSE.Procedures.ResultType,System.String,System.Drawing.Bitmap)"]

bitmap
Type: System.DrawingBitmap

[Missing <param name="bitmap"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddBitmapResult(Tango.FSE.Procedures.ResultType,System.String,System.Drawing.Bitmap)"]

Return Value

Type: Result

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddBitmapResult(Tango.FSE.Procedures.ResultType,System.String,System.Drawing.Bitmap)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.AddGraphResult Method

IProcedureContextAddGraphResult Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddGraphResult(Tango.FSE.Procedures.ResultType,System.String,System.Collections.Generic.IEnumerable{System.Double})"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Result AddGraphResult(
    ResultType type,
    string name,
    IEnumerable<double> values
)

Parameters

type
Type: Tango.FSE.ProceduresResultType

[Missing <param name="type"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddGraphResult(Tango.FSE.Procedures.ResultType,System.String,System.Collections.Generic.IEnumerable{System.Double})"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddGraphResult(Tango.FSE.Procedures.ResultType,System.String,System.Collections.Generic.IEnumerable{System.Double})"]

values
Type: System.Collections.GenericIEnumerableDouble

[Missing <param name="values"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddGraphResult(Tango.FSE.Procedures.ResultType,System.String,System.Collections.Generic.IEnumerable{System.Double})"]

Return Value

Type: Result

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddGraphResult(Tango.FSE.Procedures.ResultType,System.String,System.Collections.Generic.IEnumerable{System.Double})"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.AddResult Method

IProcedureContextAddResult Method

Overload List
 | Name | Description
Public method | AddResult(Result) |
Public method | AddResult(ResultType, String, Object) |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.AddResult Method (Result)

IProcedureContextAddResult Method (Result)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddResult(Tango.FSE.Procedures.Result)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Result AddResult(
    Result result
)

Parameters

result
Type: Tango.FSE.ProceduresResult

[Missing <param name="result"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddResult(Tango.FSE.Procedures.Result)"]

Return Value

Type: Result

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddResult(Tango.FSE.Procedures.Result)"]

See Also

Reference

IProcedureContext Interface
AddResult Overload
Tango.FSE.Procedures Namespace


IProcedureContext.AddResult Method (ResultType, String, Object)

IProcedureContextAddResult Method (ResultType, String, Object)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddResult(Tango.FSE.Procedures.ResultType,System.String,System.Object)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Result AddResult(
    ResultType type,
    string name,
    Object value
)

Parameters

type
Type: Tango.FSE.ProceduresResultType

[Missing <param name="type"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddResult(Tango.FSE.Procedures.ResultType,System.String,System.Object)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddResult(Tango.FSE.Procedures.ResultType,System.String,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddResult(Tango.FSE.Procedures.ResultType,System.String,System.Object)"]

Return Value

Type: Result

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AddResult(Tango.FSE.Procedures.ResultType,System.String,System.Object)"]

See Also

Reference

IProcedureContext Interface
AddResult Overload
Tango.FSE.Procedures Namespace


IProcedureContext.AppendToFile Method

IProcedureContextAppendToFile Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AppendToFile(System.String,System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void AppendToFile(
    string filePath,
    string content
)

Parameters

filePath
Type: SystemString

[Missing <param name="filePath"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AppendToFile(System.String,System.String)"]

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.AppendToFile(System.String,System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.Clear Method

IProcedureContextClear Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Clear"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Clear()
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ClearResults Method

IProcedureContextClearResults Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ClearResults"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void ClearResults()
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.CreateBitmap Method

IProcedureContextCreateBitmap Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.CreateBitmap(System.Int32,System.Int32)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Bitmap CreateBitmap(
    int width,
    int height
)

Parameters

width
Type: SystemInt32

[Missing <param name="width"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.CreateBitmap(System.Int32,System.Int32)"]

height
Type: SystemInt32

[Missing <param name="height"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.CreateBitmap(System.Int32,System.Int32)"]

Return Value

Type: Bitmap

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.CreateBitmap(System.Int32,System.Int32)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.Fail Method

IProcedureContextFail Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Fail(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Fail(
    string message
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Fail(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetDiagnosticsPackage Method

IProcedureContextGetDiagnosticsPackage Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetDiagnosticsPackage(System.Boolean)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
DiagnosticsPackage GetDiagnosticsPackage(
    bool waitForNext = false
)

Parameters

waitForNext (Optional)
Type: SystemBoolean

[Missing <param name="waitForNext"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetDiagnosticsPackage(System.Boolean)"]

Return Value

Type: DiagnosticsPackage

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetDiagnosticsPackage(System.Boolean)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetDrawingContext Method

IProcedureContextGetDrawingContext Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetDrawingContext(System.Drawing.Bitmap)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Graphics GetDrawingContext(
    Bitmap bitmap
)

Parameters

bitmap
Type: System.DrawingBitmap

[Missing <param name="bitmap"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetDrawingContext(System.Drawing.Bitmap)"]

Return Value

Type: Graphics

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetDrawingContext(System.Drawing.Bitmap)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetFileBytes Method

IProcedureContextGetFileBytes Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetFileBytes(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
byte[] GetFileBytes(
    string path
)

Parameters

path
Type: SystemString

[Missing <param name="path"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetFileBytes(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetFileBytes(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetFileText Method

IProcedureContextGetFileText Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetFileText(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string GetFileText(
    string path
)

Parameters

path
Type: SystemString

[Missing <param name="path"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetFileText(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetFileText(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetInput Method

IProcedureContextGetInput Method

Overload List
 | Name | Description
Public method | GetInputT(String) |
Public method | GetInput(String) |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetInput(T) Method (String)

IProcedureContextGetInputT Method (String)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInput``1(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
T GetInput<T>(
    string key
)

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInput``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInput``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInput``1(System.String)"]

See Also

Reference

IProcedureContext Interface
GetInput Overload
Tango.FSE.Procedures Namespace


IProcedureContext.GetInput Method (String)

IProcedureContextGetInput Method (String)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInput(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Object GetInput(
    string key
)

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInput(System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInput(System.String)"]

See Also

Reference

IProcedureContext Interface
GetInput Overload
Tango.FSE.Procedures Namespace


IProcedureContext.GetInputArray(T) Method

IProcedureContextGetInputArrayT Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInputArray``1(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
List<T> GetInputArray<T>(
    string key
)

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInputArray``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInputArray``1(System.String)"]

Return Value

Type: ListT

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetInputArray``1(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetRemoteDataStoreManager Method

IProcedureContextGetRemoteDataStoreManager Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetRemoteDataStoreManager"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IRemoteDataStoreManager GetRemoteDataStoreManager()

Return Value

Type: IRemoteDataStoreManager

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetRemoteDataStoreManager"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetResourceBytes Method

IProcedureContextGetResourceBytes Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetResourceBytes(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
byte[] GetResourceBytes(
    string resourceName
)

Parameters

resourceName
Type: SystemString

[Missing <param name="resourceName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetResourceBytes(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetResourceBytes(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetResourceString Method

IProcedureContextGetResourceString Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetResourceString(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string GetResourceString(
    string resourceName
)

Parameters

resourceName
Type: SystemString

[Missing <param name="resourceName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetResourceString(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetResourceString(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetService(T) Method

IProcedureContextGetServiceT Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetService``1"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
T GetService<T>()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetService``1"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetService``1"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetVariable Method

IProcedureContextGetVariable Method

Overload List
 | Name | Description
Public method | GetVariable(String) |
Public method | GetVariableT(String) |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.GetVariable Method (String)

IProcedureContextGetVariable Method (String)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariable(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Object GetVariable(
    string name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariable(System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariable(System.String)"]

See Also

Reference

IProcedureContext Interface
GetVariable Overload
Tango.FSE.Procedures Namespace


IProcedureContext.GetVariable(T) Method (String)

IProcedureContextGetVariableT Method (String)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariable``1(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
T GetVariable<T>(
    string name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariable``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariable``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariable``1(System.String)"]

See Also

Reference

IProcedureContext Interface
GetVariable Overload
Tango.FSE.Procedures Namespace


IProcedureContext.GetVariableArray(T) Method

IProcedureContextGetVariableArrayT Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariableArray``1(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
List<T> GetVariableArray<T>(
    string name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariableArray``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariableArray``1(System.String)"]

Return Value

Type: ListT

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.GetVariableArray``1(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.LoadDialog Method

IProcedureContextLoadDialog Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.LoadDialog(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IDialogController LoadDialog(
    string name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.LoadDialog(System.String)"]

Return Value

Type: IDialogController

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.LoadDialog(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.LoadDialogAsWindow Method

IProcedureContextLoadDialogAsWindow Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.LoadDialogAsWindow(System.String,System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IDialogWindowController LoadDialogAsWindow(
    string name,
    string windowTitle
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.LoadDialogAsWindow(System.String,System.String)"]

windowTitle
Type: SystemString

[Missing <param name="windowTitle"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.LoadDialogAsWindow(System.String,System.String)"]

Return Value

Type: IDialogWindowController

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.LoadDialogAsWindow(System.String,System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.OpenResource Method

IProcedureContextOpenResource Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.OpenResource(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void OpenResource(
    string resourceName
)

Parameters

resourceName
Type: SystemString

[Missing <param name="resourceName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.OpenResource(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ReadCsv Method

IProcedureContextReadCsv Method

Overload List
 | Name | Description
Public method | ReadCsvT(Byte) |
Public method | ReadCsvT(String) |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ReadCsv(T) Method (Byte[])

IProcedureContextReadCsvT Method (Byte)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ReadCsv``1(System.Byte[])"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
List<T> ReadCsv<T>(
    byte[] data
)
where T : class, new()

Parameters

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ReadCsv``1(System.Byte[])"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ReadCsv``1(System.Byte[])"]

Return Value

Type: ListT

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ReadCsv``1(System.Byte[])"]

See Also

Reference

IProcedureContext Interface
ReadCsv Overload
Tango.FSE.Procedures Namespace


IProcedureContext.ReadCsv(T) Method (String)

IProcedureContextReadCsvT Method (String)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ReadCsv``1(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
List<T> ReadCsv<T>(
    string file
)
where T : class, new()

Parameters

file
Type: SystemString

[Missing <param name="file"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ReadCsv``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ReadCsv``1(System.String)"]

Return Value

Type: ListT

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ReadCsv``1(System.String)"]

See Also

Reference

IProcedureContext Interface
ReadCsv Overload
Tango.FSE.Procedures Namespace


IProcedureContext.RemoveResult Method

IProcedureContextRemoveResult Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RemoveResult(Tango.FSE.Procedures.Result)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void RemoveResult(
    Result result
)

Parameters

result
Type: Tango.FSE.ProceduresResult

[Missing <param name="result"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RemoveResult(Tango.FSE.Procedures.Result)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.RequestFileOpen Method

IProcedureContextRequestFileOpen Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFileOpen(System.String,System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string RequestFileOpen(
    string message,
    string extension = "*.*"
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFileOpen(System.String,System.String)"]

extension (Optional)
Type: SystemString

[Missing <param name="extension"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFileOpen(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFileOpen(System.String,System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.RequestFileSave Method

IProcedureContextRequestFileSave Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFileSave(System.String,System.String,System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string RequestFileSave(
    string message,
    string extension = "*.*",
    string defaultFileName = null
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFileSave(System.String,System.String,System.String)"]

extension (Optional)
Type: SystemString

[Missing <param name="extension"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFileSave(System.String,System.String,System.String)"]

defaultFileName (Optional)
Type: SystemString

[Missing <param name="defaultFileName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFileSave(System.String,System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFileSave(System.String,System.String,System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.RequestFolderSelect Method

IProcedureContextRequestFolderSelect Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFolderSelect(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string RequestFolderSelect(
    string message
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFolderSelect(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestFolderSelect(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.RequestUserInputFor Method

IProcedureContextRequestUserInputFor Method

Overload List
 | Name | Description
Public method | RequestUserInputForT(String, String) |
Public method | RequestUserInputForT(T, String, String) |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.RequestUserInputFor(T) Method (String, String)

IProcedureContextRequestUserInputForT Method (String, String)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(System.String,System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
T RequestUserInputFor<T>(
    string title,
    string message
)

Parameters

title
Type: SystemString

[Missing <param name="title"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(System.String,System.String)"]

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(System.String,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(System.String,System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(System.String,System.String)"]

See Also

Reference

IProcedureContext Interface
RequestUserInputFor Overload
Tango.FSE.Procedures Namespace


IProcedureContext.RequestUserInputFor(T) Method (T, String, String)

IProcedureContextRequestUserInputForT Method (T, String, String)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(``0,System.String,System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
T RequestUserInputFor<T>(
    T model,
    string title,
    string message
)

Parameters

model
Type: T

[Missing <param name="model"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(``0,System.String,System.String)"]

title
Type: SystemString

[Missing <param name="title"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(``0,System.String,System.String)"]

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(``0,System.String,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(``0,System.String,System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RequestUserInputFor``1(``0,System.String,System.String)"]

See Also

Reference

IProcedureContext Interface
RequestUserInputFor Overload
Tango.FSE.Procedures Namespace


IProcedureContext.RunAsync Method

IProcedureContextRunAsync Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RunAsync(System.Action)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Thread RunAsync(
    Action action
)

Parameters

action
Type: SystemAction

[Missing <param name="action"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RunAsync(System.Action)"]

Return Value

Type: Thread

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.RunAsync(System.Action)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.Send Method

IProcedureContextSend Method

Overload List
 | Name | Description
Public method | Send(IMessage, NullableInt32) |
Public method | SendT(IMessage, NullableInt32) |
Public method | Send(String, Object) |
Public method | SendT(String, Object) |
Public method | Send(String, NullableTimeSpan, Object) |
Public method | SendT(String, NullableTimeSpan, Object) |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.Send Method (IMessage, Nullable(Int32))

IProcedureContextSend Method (IMessage, NullableInt32)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(Google.Protobuf.IMessage,System.Nullable{System.Int32})"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IMessage Send(
    IMessage message,
    Nullable<int> timeout = null
)

Parameters

message
Type: IMessage

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(Google.Protobuf.IMessage,System.Nullable{System.Int32})"]

timeout (Optional)
Type: SystemNullableInt32

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(Google.Protobuf.IMessage,System.Nullable{System.Int32})"]

Return Value

Type: IMessage

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(Google.Protobuf.IMessage,System.Nullable{System.Int32})"]

See Also

Reference

IProcedureContext Interface
Send Overload
Tango.FSE.Procedures Namespace


IProcedureContext.Send(T) Method (IMessage, Nullable(Int32))

IProcedureContextSendT Method (IMessage, NullableInt32)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(Google.Protobuf.IMessage,System.Nullable{System.Int32})"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
T Send<T>(
    IMessage message,
    Nullable<int> timeout = null
)
where T : class, IMessage

Parameters

message
Type: IMessage

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(Google.Protobuf.IMessage,System.Nullable{System.Int32})"]

timeout (Optional)
Type: SystemNullableInt32

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(Google.Protobuf.IMessage,System.Nullable{System.Int32})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(Google.Protobuf.IMessage,System.Nullable{System.Int32})"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(Google.Protobuf.IMessage,System.Nullable{System.Int32})"]

See Also

Reference

IProcedureContext Interface
Send Overload
Tango.FSE.Procedures Namespace


IProcedureContext.Send Method (String, Object[])

IProcedureContextSend Method (String, Object)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(System.String,System.Object[])"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IMessage Send(
    string messageName,
    params Object[] args
)

Parameters

messageName
Type: SystemString

[Missing <param name="messageName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(System.String,System.Object[])"]

Return Value

Type: IMessage

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(System.String,System.Object[])"]

See Also

Reference

IProcedureContext Interface
Send Overload
Tango.FSE.Procedures Namespace


IProcedureContext.Send(T) Method (String, Object[])

IProcedureContextSendT Method (String, Object)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Object[])"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
T Send<T>(
    string messageName,
    params Object[] args
)
where T : class, IMessage

Parameters

messageName
Type: SystemString

[Missing <param name="messageName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Object[])"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Object[])"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Object[])"]

See Also

Reference

IProcedureContext Interface
Send Overload
Tango.FSE.Procedures Namespace


IProcedureContext.Send Method (String, Nullable(TimeSpan), Object[])

IProcedureContextSend Method (String, NullableTimeSpan, Object)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IMessage Send(
    string messageName,
    Nullable<TimeSpan> timeout = null,
    params Object[] args
)

Parameters

messageName
Type: SystemString

[Missing <param name="messageName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

timeout (Optional)
Type: SystemNullableTimeSpan

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

Return Value

Type: IMessage

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

See Also

Reference

IProcedureContext Interface
Send Overload
Tango.FSE.Procedures Namespace


IProcedureContext.Send(T) Method (String, Nullable(TimeSpan), Object[])

IProcedureContextSendT Method (String, NullableTimeSpan, Object)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
T Send<T>(
    string messageName,
    Nullable<TimeSpan> timeout = null,
    params Object[] args
)
where T : class, IMessage

Parameters

messageName
Type: SystemString

[Missing <param name="messageName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

timeout (Optional)
Type: SystemNullableTimeSpan

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Send``1(System.String,System.Nullable{System.TimeSpan},System.Object[])"]

See Also

Reference

IProcedureContext Interface
Send Overload
Tango.FSE.Procedures Namespace


IProcedureContext.SendContinuous Method

IProcedureContextSendContinuous Method

Overload List
 | Name | Description
Public method | SendContinuousT(IMessage, ActionT, NullableInt32) |
Public method | SendContinuousT(String, ActionT, Object) |
Public method | SendContinuousT(String, ActionT, NullableTimeSpan, Object) |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.SendContinuous(T) Method (IMessage, Action(T), Nullable(Int32))

IProcedureContextSendContinuousT Method (IMessage, ActionT, NullableInt32)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(Google.Protobuf.IMessage,System.Action{``0},System.Nullable{System.Int32})"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void SendContinuous<T>(
    IMessage message,
    Action<T> callback,
    Nullable<int> timeout
)
where T : class, IMessage

Parameters

message
Type: IMessage

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(Google.Protobuf.IMessage,System.Action{``0},System.Nullable{System.Int32})"]

callback
Type: SystemActionT

[Missing <param name="callback"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(Google.Protobuf.IMessage,System.Action{``0},System.Nullable{System.Int32})"]

timeout
Type: SystemNullableInt32

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(Google.Protobuf.IMessage,System.Action{``0},System.Nullable{System.Int32})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(Google.Protobuf.IMessage,System.Action{``0},System.Nullable{System.Int32})"]

See Also

Reference

IProcedureContext Interface
SendContinuous Overload
Tango.FSE.Procedures Namespace


IProcedureContext.SendContinuous(T) Method (String, Action(T), Object[])

IProcedureContextSendContinuousT Method (String, ActionT, Object)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Object[])"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void SendContinuous<T>(
    string messageName,
    Action<T> callback,
    params Object[] args
)
where T : class, IMessage

Parameters

messageName
Type: SystemString

[Missing <param name="messageName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Object[])"]

callback
Type: SystemActionT

[Missing <param name="callback"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Object[])"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Object[])"]

See Also

Reference

IProcedureContext Interface
SendContinuous Overload
Tango.FSE.Procedures Namespace


IProcedureContext.SendContinuous(T) Method (String, Action(T), Nullable(TimeSpan), Object[])

IProcedureContextSendContinuousT Method (String, ActionT, NullableTimeSpan, Object)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Nullable{System.TimeSpan},System.Object[])"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void SendContinuous<T>(
    string messageName,
    Action<T> callback,
    Nullable<TimeSpan> timeout,
    params Object[] args
)
where T : class, IMessage

Parameters

messageName
Type: SystemString

[Missing <param name="messageName"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Nullable{System.TimeSpan},System.Object[])"]

callback
Type: SystemActionT

[Missing <param name="callback"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Nullable{System.TimeSpan},System.Object[])"]

timeout
Type: SystemNullableTimeSpan

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Nullable{System.TimeSpan},System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Nullable{System.TimeSpan},System.Object[])"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.SendContinuous``1(System.String,System.Action{``0},System.Nullable{System.TimeSpan},System.Object[])"]

See Also

Reference

IProcedureContext Interface
SendContinuous Overload
Tango.FSE.Procedures Namespace


IProcedureContext.ShowError Method

IProcedureContextShowError Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowError(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void ShowError(
    string message
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowError(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ShowErrorRemote Method

IProcedureContextShowErrorRemote Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowErrorRemote(System.String,System.Int32)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void ShowErrorRemote(
    string message,
    int timeout
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowErrorRemote(System.String,System.Int32)"]

timeout
Type: SystemInt32

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowErrorRemote(System.String,System.Int32)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ShowInfo Method

IProcedureContextShowInfo Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowInfo(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void ShowInfo(
    string message
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowInfo(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ShowInfoRemote Method

IProcedureContextShowInfoRemote Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowInfoRemote(System.String,System.Int32)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void ShowInfoRemote(
    string message,
    int timeout
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowInfoRemote(System.String,System.Int32)"]

timeout
Type: SystemInt32

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowInfoRemote(System.String,System.Int32)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ShowQuestion Method

IProcedureContextShowQuestion Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowQuestion(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool ShowQuestion(
    string message
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowQuestion(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowQuestion(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ShowQuestionRemote Method

IProcedureContextShowQuestionRemote Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowQuestionRemote(System.String,System.Int32)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool ShowQuestionRemote(
    string message,
    int timeout
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowQuestionRemote(System.String,System.Int32)"]

timeout
Type: SystemInt32

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowQuestionRemote(System.String,System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowQuestionRemote(System.String,System.Int32)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ShowWarning Method

IProcedureContextShowWarning Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowWarning(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void ShowWarning(
    string message
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowWarning(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ShowWarningQuestion Method

IProcedureContextShowWarningQuestion Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowWarningQuestion(System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool ShowWarningQuestion(
    string message
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowWarningQuestion(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowWarningQuestion(System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.ShowWarningRemote Method

IProcedureContextShowWarningRemote Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowWarningRemote(System.String,System.Int32)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void ShowWarningRemote(
    string message,
    int timeout
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowWarningRemote(System.String,System.Int32)"]

timeout
Type: SystemInt32

[Missing <param name="timeout"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.ShowWarningRemote(System.String,System.Int32)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.Sleep Method

IProcedureContextSleep Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Sleep(System.Int32)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Sleep(
    int milliseconds
)

Parameters

milliseconds
Type: SystemInt32

[Missing <param name="milliseconds"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Sleep(System.Int32)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.UpdateProgress Method

IProcedureContextUpdateProgress Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.UpdateProgress(System.String,System.Boolean,System.Double,System.Double)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void UpdateProgress(
    string message,
    bool isIndeterminate = true,
    double value = 0,
    double maximum = 100
)

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.UpdateProgress(System.String,System.Boolean,System.Double,System.Double)"]

isIndeterminate (Optional)
Type: SystemBoolean

[Missing <param name="isIndeterminate"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.UpdateProgress(System.String,System.Boolean,System.Double,System.Double)"]

value (Optional)
Type: SystemDouble

[Missing <param name="value"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.UpdateProgress(System.String,System.Boolean,System.Double,System.Double)"]

maximum (Optional)
Type: SystemDouble

[Missing <param name="maximum"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.UpdateProgress(System.String,System.Boolean,System.Double,System.Double)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.Write Method

IProcedureContextWrite Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Write(System.Object)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Write(
    Object obj
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.Write(System.Object)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.WriteCsv(T) Method

IProcedureContextWriteCsvT Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteCsv``1(System.String,System.Collections.Generic.List{``0})"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void WriteCsv<T>(
    string file,
    List<T> items
)

Parameters

file
Type: SystemString

[Missing <param name="file"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteCsv``1(System.String,System.Collections.Generic.List{``0})"]

items
Type: System.Collections.GenericListT

[Missing <param name="items"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteCsv``1(System.String,System.Collections.Generic.List{``0})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteCsv``1(System.String,System.Collections.Generic.List{``0})"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.WriteHex Method

IProcedureContextWriteHex Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteHex(System.Object,System.Int32)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void WriteHex(
    Object number,
    int digits
)

Parameters

number
Type: SystemObject

[Missing <param name="number"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteHex(System.Object,System.Int32)"]

digits
Type: SystemInt32

[Missing <param name="digits"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteHex(System.Object,System.Int32)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.WriteLine Method

IProcedureContextWriteLine Method

Overload List
 | Name | Description
Public method | WriteLine |
Public method | WriteLine(Object) |
Top
See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.WriteLine Method

IProcedureContextWriteLine Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteLine"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void WriteLine()
See Also

Reference

IProcedureContext Interface
WriteLine Overload
Tango.FSE.Procedures Namespace


IProcedureContext.WriteLine Method (Object)

IProcedureContextWriteLine Method (Object)

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteLine(System.Object)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void WriteLine(
    Object obj
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteLine(System.Object)"]

See Also

Reference

IProcedureContext Interface
WriteLine Overload
Tango.FSE.Procedures Namespace


IProcedureContext.WriteLineArray Method

IProcedureContextWriteLineArray Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteLineArray(System.Collections.IEnumerable,Tango.FSE.Procedures.ArrayParsingStyle)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void WriteLineArray(
    IEnumerable array,
    ArrayParsingStyle style
)

Parameters

array
Type: System.CollectionsIEnumerable

[Missing <param name="array"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteLineArray(System.Collections.IEnumerable,Tango.FSE.Procedures.ArrayParsingStyle)"]

style
Type: Tango.FSE.ProceduresArrayParsingStyle

[Missing <param name="style"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteLineArray(System.Collections.IEnumerable,Tango.FSE.Procedures.ArrayParsingStyle)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.WriteLineHex Method

IProcedureContextWriteLineHex Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteLineHex(System.Object,System.Int32)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void WriteLineHex(
    Object number,
    int digits
)

Parameters

number
Type: SystemObject

[Missing <param name="number"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteLineHex(System.Object,System.Int32)"]

digits
Type: SystemInt32

[Missing <param name="digits"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteLineHex(System.Object,System.Int32)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


IProcedureContext.WriteToFile Method

IProcedureContextWriteToFile Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteToFile(System.String,System.String)"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void WriteToFile(
    string filePath,
    string content
)

Parameters

filePath
Type: SystemString

[Missing <param name="filePath"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteToFile(System.String,System.String)"]

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Tango.FSE.Procedures.IProcedureContext.WriteToFile(System.String,System.String)"]

See Also

Reference

IProcedureContext Interface
Tango.FSE.Procedures Namespace


Result Class

[Missing <summary> documentation for "T:Tango.FSE.Procedures.Result"]

Inheritance Hierarchy
SystemObject
Tango.FSE.ProceduresResult

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class Result

The Result type exposes the following members.

Constructors
 | Name | Description
Public method | Result | Initializes a new instance of the Result class
Public method | Result(ResultType, String, Object) | Initializes a new instance of the Result class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Type |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Tango.FSE.Procedures Namespace


Result Constructor

Overload List
 | Name | Description
Public method | Result | Initializes a new instance of the Result class
Public method | Result(ResultType, String, Object) | Initializes a new instance of the Result class
Top
See Also

Reference

Result Class
Tango.FSE.Procedures Namespace


Result Constructor

Initializes a new instance of the Result class

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Result()
See Also

Reference

Result Class
Result Overload
Tango.FSE.Procedures Namespace


Result Constructor (ResultType, String, Object)

Initializes a new instance of the Result class

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Result(
    ResultType type,
    string name,
    Object value
)

Parameters

type
Type: Tango.FSE.ProceduresResultType

[Missing <param name="type"/> documentation for "M:Tango.FSE.Procedures.Result.#ctor(Tango.FSE.Procedures.ResultType,System.String,System.Object)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.Result.#ctor(Tango.FSE.Procedures.ResultType,System.String,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Tango.FSE.Procedures.Result.#ctor(Tango.FSE.Procedures.ResultType,System.String,System.Object)"]

See Also

Reference

Result Class
Result Overload
Tango.FSE.Procedures Namespace


Result Properties

The Result type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Type |
Public property | Value |
Top
See Also

Reference

Result Class
Tango.FSE.Procedures Namespace


Result.Name Property

ResultName Property

[Missing <summary> documentation for "P:Tango.FSE.Procedures.Result.Name"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Result Class
Tango.FSE.Procedures Namespace


Result.Type Property

ResultType Property

[Missing <summary> documentation for "P:Tango.FSE.Procedures.Result.Type"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ResultType Type { get; set; }

Property Value

Type: ResultType
See Also

Reference

Result Class
Tango.FSE.Procedures Namespace


Result.Value Property

ResultValue Property

[Missing <summary> documentation for "P:Tango.FSE.Procedures.Result.Value"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Object Value { get; set; }

Property Value

Type: Object
See Also

Reference

Result Class
Tango.FSE.Procedures Namespace


Result Methods

The Result type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Result Class
Tango.FSE.Procedures Namespace


Result.ToString Method

ResultToString Method

[Missing <summary> documentation for "M:Tango.FSE.Procedures.Result.ToString"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.FSE.Procedures.Result.ToString"]

See Also

Reference

Result Class
Tango.FSE.Procedures Namespace


ResultType Enumeration

[Missing <summary> documentation for "T:Tango.FSE.Procedures.ResultType"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum ResultType
Members
Member name | Value | Description
Passed | 0 |
Failed | 1 |
Warning | 2 |
See Also

Reference

Tango.FSE.Procedures Namespace


UserInput Class

[Missing <summary> documentation for "T:Tango.FSE.Procedures.UserInput"]

Inheritance Hierarchy
SystemObject
SystemAttribute
Tango.FSE.ProceduresUserInput

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public class UserInput : Attribute

The UserInput type exposes the following members.

Constructors
 | Name | Description
Public method | UserInput | Initializes a new instance of the UserInput class
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.FSE.Procedures Namespace


UserInput Constructor

Initializes a new instance of the UserInput class

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public UserInput(
    string name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.FSE.Procedures.UserInput.#ctor(System.String)"]

See Also

Reference

UserInput Class
Tango.FSE.Procedures Namespace


UserInput Properties

The UserInput type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

UserInput Class
Tango.FSE.Procedures Namespace


UserInput.Name Property

UserInputName Property

[Missing <summary> documentation for "P:Tango.FSE.Procedures.UserInput.Name"]

Namespace: Tango.FSE.Procedures
Assembly: Tango.FSE.Procedures (in Tango.FSE.Procedures.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

UserInput Class
Tango.FSE.Procedures Namespace


UserInput Methods

The UserInput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UserInput Class
Tango.FSE.Procedures Namespace


Tango.PPC.Shared.Events Namespace

Classes
 | Class | Description
Public class | PushEmulatedEventRequest |
Public class | PushEmulatedEventResponse |


PushEmulatedEventRequest Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Events.PushEmulatedEventRequest"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.EventsPushEmulatedEventRequest

Namespace: Tango.PPC.Shared.Events
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class PushEmulatedEventRequest

The PushEmulatedEventRequest type exposes the following members.

Constructors
 | Name | Description
Public method | PushEmulatedEventRequest | Initializes a new instance of the PushEmulatedEventRequest class
Top
Properties
 | Name | Description
Public property | Event |
Public property | Timeout |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Events Namespace


PushEmulatedEventRequest Constructor

Initializes a new instance of the PushEmulatedEventRequest class

Namespace: Tango.PPC.Shared.Events
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public PushEmulatedEventRequest()
See Also

Reference

PushEmulatedEventRequest Class
Tango.PPC.Shared.Events Namespace


PushEmulatedEventRequest Properties

The PushEmulatedEventRequest type exposes the following members.

Properties
 | Name | Description
Public property | Event |
Public property | Timeout |
Top
See Also

Reference

PushEmulatedEventRequest Class
Tango.PPC.Shared.Events Namespace


PushEmulatedEventRequest.Event Property

PushEmulatedEventRequestEvent Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Events.PushEmulatedEventRequest.Event"]

Namespace: Tango.PPC.Shared.Events
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public Event Event { get; set; }

Property Value

Type: Event
See Also

Reference

PushEmulatedEventRequest Class
Tango.PPC.Shared.Events Namespace


PushEmulatedEventRequest.Timeout Property

PushEmulatedEventRequestTimeout Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Events.PushEmulatedEventRequest.Timeout"]

Namespace: Tango.PPC.Shared.Events
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public TimeSpan Timeout { get; set; }

Property Value

Type: TimeSpan
See Also

Reference

PushEmulatedEventRequest Class
Tango.PPC.Shared.Events Namespace


PushEmulatedEventRequest Methods

The PushEmulatedEventRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PushEmulatedEventRequest Class
Tango.PPC.Shared.Events Namespace


PushEmulatedEventResponse Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Events.PushEmulatedEventResponse"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.EventsPushEmulatedEventResponse

Namespace: Tango.PPC.Shared.Events
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class PushEmulatedEventResponse

The PushEmulatedEventResponse type exposes the following members.

Constructors
 | Name | Description
Public method | PushEmulatedEventResponse | Initializes a new instance of the PushEmulatedEventResponse class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Events Namespace


PushEmulatedEventResponse Constructor

Initializes a new instance of the PushEmulatedEventResponse class

Namespace: Tango.PPC.Shared.Events
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public PushEmulatedEventResponse()
See Also

Reference

PushEmulatedEventResponse Class
Tango.PPC.Shared.Events Namespace


PushEmulatedEventResponse Methods

The PushEmulatedEventResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PushEmulatedEventResponse Class
Tango.PPC.Shared.Events Namespace


Tango.PPC.Shared.Notifications Namespace

Classes
 | Class | Description
Public class | RemoteMessageBoxRequest |
Public class | RemoteMessageBoxResponse |
Enumerations
 | Enumeration | Description
Public enumeration | RemoteMessageBoxType |


RemoteMessageBoxRequest Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Notifications.RemoteMessageBoxRequest"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.NotificationsRemoteMessageBoxRequest

Namespace: Tango.PPC.Shared.Notifications
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteMessageBoxRequest

The RemoteMessageBoxRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteMessageBoxRequest | Initializes a new instance of the RemoteMessageBoxRequest class
Top
Properties
 | Name | Description
Public property | Message |
Public property | Timeout |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxRequest Constructor

Initializes a new instance of the RemoteMessageBoxRequest class

Namespace: Tango.PPC.Shared.Notifications
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteMessageBoxRequest()
See Also

Reference

RemoteMessageBoxRequest Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxRequest Properties

The RemoteMessageBoxRequest type exposes the following members.

Properties
 | Name | Description
Public property | Message |
Public property | Timeout |
Public property | Type |
Top
See Also

Reference

RemoteMessageBoxRequest Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxRequest.Message Property

RemoteMessageBoxRequestMessage Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Notifications.RemoteMessageBoxRequest.Message"]

Namespace: Tango.PPC.Shared.Notifications
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string Message { get; set; }

Property Value

Type: String
See Also

Reference

RemoteMessageBoxRequest Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxRequest.Timeout Property

RemoteMessageBoxRequestTimeout Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Notifications.RemoteMessageBoxRequest.Timeout"]

Namespace: Tango.PPC.Shared.Notifications
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public Nullable<TimeSpan> Timeout { get; set; }

Property Value

Type: NullableTimeSpan
See Also

Reference

RemoteMessageBoxRequest Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxRequest.Type Property

RemoteMessageBoxRequestType Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Notifications.RemoteMessageBoxRequest.Type"]

Namespace: Tango.PPC.Shared.Notifications
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteMessageBoxType Type { get; set; }

Property Value

Type: RemoteMessageBoxType
See Also

Reference

RemoteMessageBoxRequest Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxRequest Methods

The RemoteMessageBoxRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteMessageBoxRequest Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxResponse Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Notifications.RemoteMessageBoxResponse"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.NotificationsRemoteMessageBoxResponse

Namespace: Tango.PPC.Shared.Notifications
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteMessageBoxResponse

The RemoteMessageBoxResponse type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteMessageBoxResponse | Initializes a new instance of the RemoteMessageBoxResponse class
Top
Properties
 | Name | Description
Public property | Result |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxResponse Constructor

Initializes a new instance of the RemoteMessageBoxResponse class

Namespace: Tango.PPC.Shared.Notifications
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteMessageBoxResponse()
See Also

Reference

RemoteMessageBoxResponse Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxResponse Properties

The RemoteMessageBoxResponse type exposes the following members.

Properties
 | Name | Description
Public property | Result |
Top
See Also

Reference

RemoteMessageBoxResponse Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxResponse.Result Property

RemoteMessageBoxResponseResult Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Notifications.RemoteMessageBoxResponse.Result"]

Namespace: Tango.PPC.Shared.Notifications
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public bool Result { get; set; }

Property Value

Type: Boolean
See Also

Reference

RemoteMessageBoxResponse Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxResponse Methods

The RemoteMessageBoxResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteMessageBoxResponse Class
Tango.PPC.Shared.Notifications Namespace


RemoteMessageBoxType Enumeration

[Missing <summary> documentation for "T:Tango.PPC.Shared.Notifications.RemoteMessageBoxType"]

Namespace: Tango.PPC.Shared.Notifications
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public enum RemoteMessageBoxType
Members
Member name | Value | Description
Info | 0 |
Warning | 1 |
Question | 2 |
Error | 3 |
See Also

Reference

Tango.PPC.Shared.Notifications Namespace


Tango.PPC.Shared.RemoteJobUpload Namespace

Classes
 | Class | Description
Public class | RemoteJobUploadCompletedRequest |
Public class | RemoteJobUploadCompletedResponse |
Public class | RemoteJobUploadRequest |
Public class | RemoteJobUploadResponse |
Enumerations
 | Enumeration | Description
Public enumeration | RemoteJobUploadType |


RemoteJobUploadCompletedRequest Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadCompletedRequest"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.RemoteJobUploadRemoteJobUploadCompletedRequest

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteJobUploadCompletedRequest

The RemoteJobUploadCompletedRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteJobUploadCompletedRequest | Initializes a new instance of the RemoteJobUploadCompletedRequest class
Top
Properties
 | Name | Description
Public property | ID |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadCompletedRequest Constructor

Initializes a new instance of the RemoteJobUploadCompletedRequest class

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteJobUploadCompletedRequest()
See Also

Reference

RemoteJobUploadCompletedRequest Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadCompletedRequest Properties

The RemoteJobUploadCompletedRequest type exposes the following members.

Properties
 | Name | Description
Public property | ID |
Top
See Also

Reference

RemoteJobUploadCompletedRequest Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadCompletedRequest.ID Property

RemoteJobUploadCompletedRequestID Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadCompletedRequest.ID"]

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string ID { get; set; }

Property Value

Type: String
See Also

Reference

RemoteJobUploadCompletedRequest Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadCompletedRequest Methods

The RemoteJobUploadCompletedRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteJobUploadCompletedRequest Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadCompletedResponse Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadCompletedResponse"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.RemoteJobUploadRemoteJobUploadCompletedResponse

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteJobUploadCompletedResponse

The RemoteJobUploadCompletedResponse type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteJobUploadCompletedResponse | Initializes a new instance of the RemoteJobUploadCompletedResponse class
Top
Properties
 | Name | Description
Public property | Error |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadCompletedResponse Constructor

Initializes a new instance of the RemoteJobUploadCompletedResponse class

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteJobUploadCompletedResponse()
See Also

Reference

RemoteJobUploadCompletedResponse Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadCompletedResponse Properties

The RemoteJobUploadCompletedResponse type exposes the following members.

Properties
 | Name | Description
Public property | Error |
Top
See Also

Reference

RemoteJobUploadCompletedResponse Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadCompletedResponse.Error Property

RemoteJobUploadCompletedResponseError Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadCompletedResponse.Error"]

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string Error { get; set; }

Property Value

Type: String
See Also

Reference

RemoteJobUploadCompletedResponse Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadCompletedResponse Methods

The RemoteJobUploadCompletedResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteJobUploadCompletedResponse Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadRequest Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadRequest"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.RemoteJobUploadRemoteJobUploadRequest

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteJobUploadRequest

The RemoteJobUploadRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteJobUploadRequest | Initializes a new instance of the RemoteJobUploadRequest class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadRequest Constructor

Initializes a new instance of the RemoteJobUploadRequest class

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteJobUploadRequest()
See Also

Reference

RemoteJobUploadRequest Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadRequest Properties

The RemoteJobUploadRequest type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Type |
Top
See Also

Reference

RemoteJobUploadRequest Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadRequest.Name Property

RemoteJobUploadRequestName Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadRequest.Name"]

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

RemoteJobUploadRequest Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadRequest.Type Property

RemoteJobUploadRequestType Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadRequest.Type"]

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteJobUploadType Type { get; set; }

Property Value

Type: RemoteJobUploadType
See Also

Reference

RemoteJobUploadRequest Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadRequest Methods

The RemoteJobUploadRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteJobUploadRequest Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadResponse Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadResponse"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.RemoteJobUploadRemoteJobUploadResponse

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteJobUploadResponse

The RemoteJobUploadResponse type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteJobUploadResponse | Initializes a new instance of the RemoteJobUploadResponse class
Top
Properties
 | Name | Description
Public property | ID |
Public property | TargetFilePath |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadResponse Constructor

Initializes a new instance of the RemoteJobUploadResponse class

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteJobUploadResponse()
See Also

Reference

RemoteJobUploadResponse Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadResponse Properties

The RemoteJobUploadResponse type exposes the following members.

Properties
 | Name | Description
Public property | ID |
Public property | TargetFilePath |
Top
See Also

Reference

RemoteJobUploadResponse Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadResponse.ID Property

RemoteJobUploadResponseID Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadResponse.ID"]

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string ID { get; set; }

Property Value

Type: String
See Also

Reference

RemoteJobUploadResponse Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadResponse.TargetFilePath Property

RemoteJobUploadResponseTargetFilePath Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadResponse.TargetFilePath"]

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string TargetFilePath { get; set; }

Property Value

Type: String
See Also

Reference

RemoteJobUploadResponse Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadResponse Methods

The RemoteJobUploadResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteJobUploadResponse Class
Tango.PPC.Shared.RemoteJobUpload Namespace


RemoteJobUploadType Enumeration

[Missing <summary> documentation for "T:Tango.PPC.Shared.RemoteJobUpload.RemoteJobUploadType"]

Namespace: Tango.PPC.Shared.RemoteJobUpload
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public enum RemoteJobUploadType
Members
Member name | Value | Description
CSV | 0 |
See Also

Reference

Tango.PPC.Shared.RemoteJobUpload Namespace


Tango.PPC.Shared.SQL Namespace

Classes
 | Class | Description
Public class | RemoteSqlColumn |
Public class | RemoteSqlColumnCollection |
Public class | RemoteSqlDataSet |
Public class | RemoteSqlRow |


RemoteSqlColumn Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.SQL.RemoteSqlColumn"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.SQLRemoteSqlColumn

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteSqlColumn

The RemoteSqlColumn type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteSqlColumn | Initializes a new instance of the RemoteSqlColumn class
Public method | RemoteSqlColumn(String) | Initializes a new instance of the RemoteSqlColumn class
Top
Properties
 | Name | Description
Public property | Index |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Tango.PPC.Shared.SQL Namespace


RemoteSqlColumn Constructor

Overload List
 | Name | Description
Public method | RemoteSqlColumn | Initializes a new instance of the RemoteSqlColumn class
Public method | RemoteSqlColumn(String) | Initializes a new instance of the RemoteSqlColumn class
Top
See Also

Reference

RemoteSqlColumn Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumn Constructor

Initializes a new instance of the RemoteSqlColumn class

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteSqlColumn()
See Also

Reference

RemoteSqlColumn Class
RemoteSqlColumn Overload
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumn Constructor (String)

Initializes a new instance of the RemoteSqlColumn class

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteSqlColumn(
    string name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlColumn.#ctor(System.String)"]

See Also

Reference

RemoteSqlColumn Class
RemoteSqlColumn Overload
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumn Properties

The RemoteSqlColumn type exposes the following members.

Properties
 | Name | Description
Public property | Index |
Public property | Name |
Top
See Also

Reference

RemoteSqlColumn Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumn.Index Property

RemoteSqlColumnIndex Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.SQL.RemoteSqlColumn.Index"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int Index { get; set; }

Property Value

Type: Int32
See Also

Reference

RemoteSqlColumn Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumn.Name Property

RemoteSqlColumnName Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.SQL.RemoteSqlColumn.Name"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

RemoteSqlColumn Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumn Methods

The RemoteSqlColumn type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

RemoteSqlColumn Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumn.ToString Method

RemoteSqlColumnToString Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlColumn.ToString"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlColumn.ToString"]

See Also

Reference

RemoteSqlColumn Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumnCollection Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.SQL.RemoteSqlColumnCollection"]

Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollectionRemoteSqlColumn
Tango.PPC.Shared.SQLRemoteSqlColumnCollection

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteSqlColumnCollection : Collection<RemoteSqlColumn>

The RemoteSqlColumnCollection type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteSqlColumnCollection | Initializes a new instance of the RemoteSqlColumnCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionRemoteSqlColumn .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionRemoteSqlColumn .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexOf |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionRemoteSqlColumn .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.SQL Namespace


RemoteSqlColumnCollection Constructor

Initializes a new instance of the RemoteSqlColumnCollection class

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteSqlColumnCollection()
See Also

Reference

RemoteSqlColumnCollection Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumnCollection Properties

The RemoteSqlColumnCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionRemoteSqlColumn .)
Top
See Also

Reference

RemoteSqlColumnCollection Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumnCollection Methods

The RemoteSqlColumnCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionRemoteSqlColumn .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIndexOf |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionRemoteSqlColumn .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionRemoteSqlColumn .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteSqlColumnCollection Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlColumnCollection.GetIndexOf Method

RemoteSqlColumnCollectionGetIndexOf Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlColumnCollection.GetIndexOf(System.String)"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int GetIndexOf(
    string columnName
)

Parameters

columnName
Type: SystemString

[Missing <param name="columnName"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlColumnCollection.GetIndexOf(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlColumnCollection.GetIndexOf(System.String)"]

See Also

Reference

RemoteSqlColumnCollection Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlDataSet Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.SQL.RemoteSqlDataSet"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.SQLRemoteSqlDataSet

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteSqlDataSet

The RemoteSqlDataSet type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteSqlDataSet | Initializes a new instance of the RemoteSqlDataSet class
Top
Properties
 | Name | Description
Public property | Columns |
Public property | Rows |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load |
Public method | ToString | (Overrides ObjectToString.)
Public method | ToTableString |
Top
See Also

Reference

Tango.PPC.Shared.SQL Namespace


RemoteSqlDataSet Constructor

Initializes a new instance of the RemoteSqlDataSet class

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteSqlDataSet()
See Also

Reference

RemoteSqlDataSet Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlDataSet Properties

The RemoteSqlDataSet type exposes the following members.

Properties
 | Name | Description
Public property | Columns |
Public property | Rows |
Top
See Also

Reference

RemoteSqlDataSet Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlDataSet.Columns Property

RemoteSqlDataSetColumns Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.SQL.RemoteSqlDataSet.Columns"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteSqlColumnCollection Columns { get; set; }

Property Value

Type: RemoteSqlColumnCollection
See Also

Reference

RemoteSqlDataSet Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlDataSet.Rows Property

RemoteSqlDataSetRows Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.SQL.RemoteSqlDataSet.Rows"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public ObservableCollection<RemoteSqlRow> Rows { get; set; }

Property Value

Type: ObservableCollectionRemoteSqlRow
See Also

Reference

RemoteSqlDataSet Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlDataSet Methods

The RemoteSqlDataSet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load |
Public method | ToString | (Overrides ObjectToString.)
Public method | ToTableString |
Top
See Also

Reference

RemoteSqlDataSet Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlDataSet.Load Method

RemoteSqlDataSetLoad Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlDataSet.Load(System.Data.SqlClient.SqlDataReader)"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public static Task<RemoteSqlDataSet> Load(
    SqlDataReader reader
)

Parameters

reader
Type: System.Data.SqlClientSqlDataReader

[Missing <param name="reader"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlDataSet.Load(System.Data.SqlClient.SqlDataReader)"]

Return Value

Type: TaskRemoteSqlDataSet

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlDataSet.Load(System.Data.SqlClient.SqlDataReader)"]

See Also

Reference

RemoteSqlDataSet Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlDataSet.ToString Method

RemoteSqlDataSetToString Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlDataSet.ToString"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlDataSet.ToString"]

See Also

Reference

RemoteSqlDataSet Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlDataSet.ToTableString Method

RemoteSqlDataSetToTableString Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlDataSet.ToTableString"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string ToTableString()

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlDataSet.ToTableString"]

See Also

Reference

RemoteSqlDataSet Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.SQL.RemoteSqlRow"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.SQLRemoteSqlRow

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RemoteSqlRow

The RemoteSqlRow type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteSqlRow | Initializes a new instance of the RemoteSqlRow class
Top
Properties
 | Name | Description
Public property | Values |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Get(Int32) |
Public method | Get(String) |
Public method | GetT(Int32) |
Public method | GetT(String) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MapT |
Public method | MapT(T) |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Tango.PPC.Shared.SQL Namespace


RemoteSqlRow Constructor

Initializes a new instance of the RemoteSqlRow class

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RemoteSqlRow()
See Also

Reference

RemoteSqlRow Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow Properties

The RemoteSqlRow type exposes the following members.

Properties
 | Name | Description
Public property | Values |
Top
See Also

Reference

RemoteSqlRow Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.Values Property

RemoteSqlRowValues Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.SQL.RemoteSqlRow.Values"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<Object> Values { get; set; }

Property Value

Type: ListObject
See Also

Reference

RemoteSqlRow Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow Methods

The RemoteSqlRow type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Get(Int32) |
Public method | Get(String) |
Public method | GetT(Int32) |
Public method | GetT(String) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MapT |
Public method | MapT(T) |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

RemoteSqlRow Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.Get Method

RemoteSqlRowGet Method

Overload List
 | Name | Description
Public method | Get(Int32) |
Public method | GetT(Int32) |
Public method | Get(String) |
Public method | GetT(String) |
Top
See Also

Reference

RemoteSqlRow Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.Get Method (Int32)

RemoteSqlRowGet Method (Int32)

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get(System.Int32)"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public Object Get(
    int columnIndex
)

Parameters

columnIndex
Type: SystemInt32

[Missing <param name="columnIndex"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get(System.Int32)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get(System.Int32)"]

See Also

Reference

RemoteSqlRow Class
Get Overload
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.Get(T) Method (Int32)

RemoteSqlRowGetT Method (Int32)

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get``1(System.Int32)"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public T Get<T>(
    int columnIndex
)

Parameters

columnIndex
Type: SystemInt32

[Missing <param name="columnIndex"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get``1(System.Int32)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get``1(System.Int32)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get``1(System.Int32)"]

See Also

Reference

RemoteSqlRow Class
Get Overload
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.Get Method (String)

RemoteSqlRowGet Method (String)

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get(System.String)"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public Object Get(
    string columnName
)

Parameters

columnName
Type: SystemString

[Missing <param name="columnName"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get(System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get(System.String)"]

See Also

Reference

RemoteSqlRow Class
Get Overload
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.Get(T) Method (String)

RemoteSqlRowGetT Method (String)

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get``1(System.String)"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public T Get<T>(
    string columnName
)

Parameters

columnName
Type: SystemString

[Missing <param name="columnName"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Get``1(System.String)"]

See Also

Reference

RemoteSqlRow Class
Get Overload
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.Map Method

RemoteSqlRowMap Method

Overload List
 | Name | Description
Public method | MapT |
Public method | MapT(T) |
Top
See Also

Reference

RemoteSqlRow Class
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.Map(T) Method

RemoteSqlRowMapT Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Map``1"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public T Map<T>()
where T : class, new()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Map``1"]

Return Value

Type: T

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Map``1"]

See Also

Reference

RemoteSqlRow Class
Map Overload
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.Map(T) Method (T)

RemoteSqlRowMapT Method (T)

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Map``1(``0)"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public void Map<T>(
    T obj
)
where T : class

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Map``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.Map``1(``0)"]

See Also

Reference

RemoteSqlRow Class
Map Overload
Tango.PPC.Shared.SQL Namespace


RemoteSqlRow.ToString Method

RemoteSqlRowToString Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.ToString"]

Namespace: Tango.PPC.Shared.SQL
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String

[Missing <returns> documentation for "M:Tango.PPC.Shared.SQL.RemoteSqlRow.ToString"]

See Also

Reference

RemoteSqlRow Class
Tango.PPC.Shared.SQL Namespace


Tango.PPC.Shared.Statistics Namespace

Classes
 | Class | Description
Public class | Filters |
Public class | GetJobRunExtendedInfoRequest |
Public class | GetJobRunExtendedInfoResponse |
Public class | GetStatisticsRequest |
Public class | GetStatisticsRequiredFiltersRequest |
Public class | GetStatisticsRequiredFiltersResponse |
Public class | GetStatisticsResponse |
Public class | JobRunComposition |
Public class | JobRunExtendedInfo |
Public class | PresentationBrushStop |
Public class | PresentationJob |
Public class | PresentationLiquidVolume |
Public class | PresentationSegment |
Public class | RequiredFiltersData |
Public class | StartJobRunsStreamingRequest |
Public class | StartJobRunsStreamingResponse |
Public class | StatisticsResult |
Public class | StopJobRunsStreamingRequest |
Public class | StopJobRunsStreamingResponse |
Public class | ThreadFilterData |


Filters Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.Filters"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsFilters

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class Filters

The Filters type exposes the following members.

Constructors
 | Name | Description
Public method | Filters | Initializes a new instance of the Filters class
Top
Properties
 | Name | Description
Public property | EndDateUTC |
Public property | EndStatuses |
Public property | ExactJobName |
Public property | IncludeHeadCleaning |
Public property | JobDesignation |
Public property | JobName |
Public property | MaxLength |
Public property | MinLength |
Public property | RmlGuids |
Public property | StartDateUTC |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


Filters Constructor

Initializes a new instance of the Filters class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public Filters()
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters Properties

The Filters type exposes the following members.

Properties
 | Name | Description
Public property | EndDateUTC |
Public property | EndStatuses |
Public property | ExactJobName |
Public property | IncludeHeadCleaning |
Public property | JobDesignation |
Public property | JobName |
Public property | MaxLength |
Public property | MinLength |
Public property | RmlGuids |
Public property | StartDateUTC |
Top
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.EndDateUTC Property

FiltersEndDateUTC Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.EndDateUTC"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public DateTime EndDateUTC { get; set; }

Property Value

Type: DateTime
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.EndStatuses Property

FiltersEndStatuses Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.EndStatuses"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<int> EndStatuses { get; set; }

Property Value

Type: ListInt32
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.ExactJobName Property

FiltersExactJobName Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.ExactJobName"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public bool ExactJobName { get; set; }

Property Value

Type: Boolean
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.IncludeHeadCleaning Property

FiltersIncludeHeadCleaning Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.IncludeHeadCleaning"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public bool IncludeHeadCleaning { get; set; }

Property Value

Type: Boolean
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.JobDesignation Property

FiltersJobDesignation Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.JobDesignation"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<int> JobDesignation { get; set; }

Property Value

Type: ListInt32
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.JobName Property

FiltersJobName Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.JobName"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string JobName { get; set; }

Property Value

Type: String
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.MaxLength Property

FiltersMaxLength Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.MaxLength"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int MaxLength { get; set; }

Property Value

Type: Int32
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.MinLength Property

FiltersMinLength Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.MinLength"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int MinLength { get; set; }

Property Value

Type: Int32
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.RmlGuids Property

FiltersRmlGuids Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.RmlGuids"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<string> RmlGuids { get; set; }

Property Value

Type: ListString
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters.StartDateUTC Property

FiltersStartDateUTC Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.Filters.StartDateUTC"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public DateTime StartDateUTC { get; set; }

Property Value

Type: DateTime
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


Filters Methods

The Filters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Filters Class
Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoRequest Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.GetJobRunExtendedInfoRequest"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsGetJobRunExtendedInfoRequest

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class GetJobRunExtendedInfoRequest

The GetJobRunExtendedInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetJobRunExtendedInfoRequest | Initializes a new instance of the GetJobRunExtendedInfoRequest class
Top
Properties
 | Name | Description
Public property | JobRunID |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoRequest Constructor

Initializes a new instance of the GetJobRunExtendedInfoRequest class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public GetJobRunExtendedInfoRequest()
See Also

Reference

GetJobRunExtendedInfoRequest Class
Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoRequest Properties

The GetJobRunExtendedInfoRequest type exposes the following members.

Properties
 | Name | Description
Public property | JobRunID |
Top
See Also

Reference

GetJobRunExtendedInfoRequest Class
Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoRequest.JobRunID Property

GetJobRunExtendedInfoRequestJobRunID Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.GetJobRunExtendedInfoRequest.JobRunID"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int JobRunID { get; set; }

Property Value

Type: Int32
See Also

Reference

GetJobRunExtendedInfoRequest Class
Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoRequest Methods

The GetJobRunExtendedInfoRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetJobRunExtendedInfoRequest Class
Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoResponse Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.GetJobRunExtendedInfoResponse"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsGetJobRunExtendedInfoResponse

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class GetJobRunExtendedInfoResponse

The GetJobRunExtendedInfoResponse type exposes the following members.

Constructors
 | Name | Description
Public method | GetJobRunExtendedInfoResponse | Initializes a new instance of the GetJobRunExtendedInfoResponse class
Top
Properties
 | Name | Description
Public property | ExtendedInfo |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoResponse Constructor

Initializes a new instance of the GetJobRunExtendedInfoResponse class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public GetJobRunExtendedInfoResponse()
See Also

Reference

GetJobRunExtendedInfoResponse Class
Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoResponse Properties

The GetJobRunExtendedInfoResponse type exposes the following members.

Properties
 | Name | Description
Public property | ExtendedInfo |
Top
See Also

Reference

GetJobRunExtendedInfoResponse Class
Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoResponse.ExtendedInfo Property

GetJobRunExtendedInfoResponseExtendedInfo Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.GetJobRunExtendedInfoResponse.ExtendedInfo"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public JobRunExtendedInfo ExtendedInfo { get; set; }

Property Value

Type: JobRunExtendedInfo
See Also

Reference

GetJobRunExtendedInfoResponse Class
Tango.PPC.Shared.Statistics Namespace


GetJobRunExtendedInfoResponse Methods

The GetJobRunExtendedInfoResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetJobRunExtendedInfoResponse Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequest Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.GetStatisticsRequest"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsGetStatisticsRequest

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class GetStatisticsRequest

The GetStatisticsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetStatisticsRequest | Initializes a new instance of the GetStatisticsRequest class
Top
Properties
 | Name | Description
Public property | Filters |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequest Constructor

Initializes a new instance of the GetStatisticsRequest class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public GetStatisticsRequest()
See Also

Reference

GetStatisticsRequest Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequest Properties

The GetStatisticsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Filters |
Top
See Also

Reference

GetStatisticsRequest Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequest.Filters Property

GetStatisticsRequestFilters Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.GetStatisticsRequest.Filters"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public Filters Filters { get; set; }

Property Value

Type: Filters
See Also

Reference

GetStatisticsRequest Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequest Methods

The GetStatisticsRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetStatisticsRequest Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequiredFiltersRequest Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.GetStatisticsRequiredFiltersRequest"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsGetStatisticsRequiredFiltersRequest

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class GetStatisticsRequiredFiltersRequest

The GetStatisticsRequiredFiltersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | GetStatisticsRequiredFiltersRequest | Initializes a new instance of the GetStatisticsRequiredFiltersRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequiredFiltersRequest Constructor

Initializes a new instance of the GetStatisticsRequiredFiltersRequest class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public GetStatisticsRequiredFiltersRequest()
See Also

Reference

GetStatisticsRequiredFiltersRequest Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequiredFiltersRequest Methods

The GetStatisticsRequiredFiltersRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetStatisticsRequiredFiltersRequest Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequiredFiltersResponse Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.GetStatisticsRequiredFiltersResponse"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsGetStatisticsRequiredFiltersResponse

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class GetStatisticsRequiredFiltersResponse

The GetStatisticsRequiredFiltersResponse type exposes the following members.

Constructors
 | Name | Description
Public method | GetStatisticsRequiredFiltersResponse | Initializes a new instance of the GetStatisticsRequiredFiltersResponse class
Top
Properties
 | Name | Description
Public property | FiltersData |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequiredFiltersResponse Constructor

Initializes a new instance of the GetStatisticsRequiredFiltersResponse class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public GetStatisticsRequiredFiltersResponse()
See Also

Reference

GetStatisticsRequiredFiltersResponse Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequiredFiltersResponse Properties

The GetStatisticsRequiredFiltersResponse type exposes the following members.

Properties
 | Name | Description
Public property | FiltersData |
Top
See Also

Reference

GetStatisticsRequiredFiltersResponse Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequiredFiltersResponse.FiltersData Property

GetStatisticsRequiredFiltersResponseFiltersData Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.GetStatisticsRequiredFiltersResponse.FiltersData"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RequiredFiltersData FiltersData { get; set; }

Property Value

Type: RequiredFiltersData
See Also

Reference

GetStatisticsRequiredFiltersResponse Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsRequiredFiltersResponse Methods

The GetStatisticsRequiredFiltersResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetStatisticsRequiredFiltersResponse Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsResponse Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.GetStatisticsResponse"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsGetStatisticsResponse

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class GetStatisticsResponse

The GetStatisticsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | GetStatisticsResponse | Initializes a new instance of the GetStatisticsResponse class
Top
Properties
 | Name | Description
Public property | Result |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


GetStatisticsResponse Constructor

Initializes a new instance of the GetStatisticsResponse class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public GetStatisticsResponse()
See Also

Reference

GetStatisticsResponse Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsResponse Properties

The GetStatisticsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Result |
Top
See Also

Reference

GetStatisticsResponse Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsResponse.Result Property

GetStatisticsResponseResult Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.GetStatisticsResponse.Result"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public StatisticsResult Result { get; set; }

Property Value

Type: StatisticsResult
See Also

Reference

GetStatisticsResponse Class
Tango.PPC.Shared.Statistics Namespace


GetStatisticsResponse Methods

The GetStatisticsResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GetStatisticsResponse Class
Tango.PPC.Shared.Statistics Namespace


JobRunComposition Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.JobRunComposition"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsJobRunComposition

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class JobRunComposition

The JobRunComposition type exposes the following members.

Constructors
 | Name | Description
Public method | JobRunComposition | Initializes a new instance of the JobRunComposition class
Top
Properties
 | Name | Description
Public property | Distance |
Public property | Job |
Public property | JobRun |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


JobRunComposition Constructor

Initializes a new instance of the JobRunComposition class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public JobRunComposition()
See Also

Reference

JobRunComposition Class
Tango.PPC.Shared.Statistics Namespace


JobRunComposition Properties

The JobRunComposition type exposes the following members.

Properties
 | Name | Description
Public property | Distance |
Public property | Job |
Public property | JobRun |
Top
See Also

Reference

JobRunComposition Class
Tango.PPC.Shared.Statistics Namespace


JobRunComposition.Distance Property

JobRunCompositionDistance Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.JobRunComposition.Distance"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public double Distance { get; }

Property Value

Type: Double
See Also

Reference

JobRunComposition Class
Tango.PPC.Shared.Statistics Namespace


JobRunComposition.Job Property

JobRunCompositionJob Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.JobRunComposition.Job"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public PresentationJob Job { get; set; }

Property Value

Type: PresentationJob
See Also

Reference

JobRunComposition Class
Tango.PPC.Shared.Statistics Namespace


JobRunComposition.JobRun Property

JobRunCompositionJobRun Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.JobRunComposition.JobRun"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public JobRunDTO JobRun { get; set; }

Property Value

Type: JobRunDTO
See Also

Reference

JobRunComposition Class
Tango.PPC.Shared.Statistics Namespace


JobRunComposition Methods

The JobRunComposition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobRunComposition Class
Tango.PPC.Shared.Statistics Namespace


JobRunExtendedInfo Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.JobRunExtendedInfo"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsJobRunExtendedInfo

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class JobRunExtendedInfo

The JobRunExtendedInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JobRunExtendedInfo | Initializes a new instance of the JobRunExtendedInfo class
Top
Properties
 | Name | Description
Public property | EndMachineStatus |
Public property | Events |
Public property | JobRunID |
Public property | JobTicket |
Public property | StartMachineStatus |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


JobRunExtendedInfo Constructor

Initializes a new instance of the JobRunExtendedInfo class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public JobRunExtendedInfo()
See Also

Reference

JobRunExtendedInfo Class
Tango.PPC.Shared.Statistics Namespace


JobRunExtendedInfo Properties

The JobRunExtendedInfo type exposes the following members.

Properties
 | Name | Description
Public property | EndMachineStatus |
Public property | Events |
Public property | JobRunID |
Public property | JobTicket |
Public property | StartMachineStatus |
Top
See Also

Reference

JobRunExtendedInfo Class
Tango.PPC.Shared.Statistics Namespace


JobRunExtendedInfo.EndMachineStatus Property

JobRunExtendedInfoEndMachineStatus Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.JobRunExtendedInfo.EndMachineStatus"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public MachineStatus EndMachineStatus { get; set; }

Property Value

Type: MachineStatus
See Also

Reference

JobRunExtendedInfo Class
Tango.PPC.Shared.Statistics Namespace


JobRunExtendedInfo.Events Property

JobRunExtendedInfoEvents Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.JobRunExtendedInfo.Events"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<MachinesEventDTO> Events { get; set; }

Property Value

Type: ListMachinesEventDTO
See Also

Reference

JobRunExtendedInfo Class
Tango.PPC.Shared.Statistics Namespace


JobRunExtendedInfo.JobRunID Property

JobRunExtendedInfoJobRunID Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.JobRunExtendedInfo.JobRunID"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int JobRunID { get; set; }

Property Value

Type: Int32
See Also

Reference

JobRunExtendedInfo Class
Tango.PPC.Shared.Statistics Namespace


JobRunExtendedInfo.JobTicket Property

JobRunExtendedInfoJobTicket Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.JobRunExtendedInfo.JobTicket"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public JobTicket JobTicket { get; set; }

Property Value

Type: JobTicket
See Also

Reference

JobRunExtendedInfo Class
Tango.PPC.Shared.Statistics Namespace


JobRunExtendedInfo.StartMachineStatus Property

JobRunExtendedInfoStartMachineStatus Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.JobRunExtendedInfo.StartMachineStatus"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public MachineStatus StartMachineStatus { get; set; }

Property Value

Type: MachineStatus
See Also

Reference

JobRunExtendedInfo Class
Tango.PPC.Shared.Statistics Namespace


JobRunExtendedInfo Methods

The JobRunExtendedInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobRunExtendedInfo Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.PresentationBrushStop"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsPresentationBrushStop

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class PresentationBrushStop

The PresentationBrushStop type exposes the following members.

Constructors
 | Name | Description
Public method | PresentationBrushStop | Initializes a new instance of the PresentationBrushStop class
Top
Properties
 | Name | Description
Public property | A |
Public property | B |
Public property | BestMatchB |
Public property | BestMatchG |
Public property | BestMatchR |
Public property | Blue |
Public property | Catalog |
Public property | CatalogItem |
Public property | ColorSpace |
Public property | Green |
Public property | L |
Public property | LiquidVolumes |
Public property | Red |
Public property | StartMeters |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLiquidVolumeInputOrZero |
Public method | GetLiquidVolumeOutputOrZero |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVolumeInputs |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop Constructor

Initializes a new instance of the PresentationBrushStop class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public PresentationBrushStop()
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop Properties

The PresentationBrushStop type exposes the following members.

Properties
 | Name | Description
Public property | A |
Public property | B |
Public property | BestMatchB |
Public property | BestMatchG |
Public property | BestMatchR |
Public property | Blue |
Public property | Catalog |
Public property | CatalogItem |
Public property | ColorSpace |
Public property | Green |
Public property | L |
Public property | LiquidVolumes |
Public property | Red |
Public property | StartMeters |
Top
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.A Property

PresentationBrushStopA Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.A"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public double A { get; set; }

Property Value

Type: Double
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.B Property

PresentationBrushStopB Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.B"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public double B { get; set; }

Property Value

Type: Double
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.BestMatchB Property

PresentationBrushStopBestMatchB Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.BestMatchB"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int BestMatchB { get; set; }

Property Value

Type: Int32
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.BestMatchG Property

PresentationBrushStopBestMatchG Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.BestMatchG"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int BestMatchG { get; set; }

Property Value

Type: Int32
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.BestMatchR Property

PresentationBrushStopBestMatchR Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.BestMatchR"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int BestMatchR { get; set; }

Property Value

Type: Int32
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.Blue Property

PresentationBrushStopBlue Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.Blue"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int Blue { get; set; }

Property Value

Type: Int32
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.Catalog Property

PresentationBrushStopCatalog Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.Catalog"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string Catalog { get; set; }

Property Value

Type: String
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.CatalogItem Property

PresentationBrushStopCatalogItem Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.CatalogItem"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string CatalogItem { get; set; }

Property Value

Type: String
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.ColorSpace Property

PresentationBrushStopColorSpace Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.ColorSpace"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public ColorSpaces ColorSpace { get; set; }

Property Value

Type: ColorSpaces
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.Green Property

PresentationBrushStopGreen Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.Green"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int Green { get; set; }

Property Value

Type: Int32
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.L Property

PresentationBrushStopL Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.L"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public double L { get; set; }

Property Value

Type: Double
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.LiquidVolumes Property

PresentationBrushStopLiquidVolumes Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.LiquidVolumes"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<PresentationLiquidVolume> LiquidVolumes { get; set; }

Property Value

Type: ListPresentationLiquidVolume
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.Red Property

PresentationBrushStopRed Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.Red"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int Red { get; set; }

Property Value

Type: Int32
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.StartMeters Property

PresentationBrushStopStartMeters Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationBrushStop.StartMeters"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public double StartMeters { get; set; }

Property Value

Type: Double
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop Methods

The PresentationBrushStop type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLiquidVolumeInputOrZero |
Public method | GetLiquidVolumeOutputOrZero |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVolumeInputs |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.GetLiquidVolumeInputOrZero Method

PresentationBrushStopGetLiquidVolumeInputOrZero Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.Statistics.PresentationBrushStop.GetLiquidVolumeInputOrZero(Tango.BL.Enumerations.LiquidTypes)"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public double GetLiquidVolumeInputOrZero(
    LiquidTypes liquidType
)

Parameters

liquidType
Type: LiquidTypes

[Missing <param name="liquidType"/> documentation for "M:Tango.PPC.Shared.Statistics.PresentationBrushStop.GetLiquidVolumeInputOrZero(Tango.BL.Enumerations.LiquidTypes)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Tango.PPC.Shared.Statistics.PresentationBrushStop.GetLiquidVolumeInputOrZero(Tango.BL.Enumerations.LiquidTypes)"]

See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.GetLiquidVolumeOutputOrZero Method

PresentationBrushStopGetLiquidVolumeOutputOrZero Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.Statistics.PresentationBrushStop.GetLiquidVolumeOutputOrZero(Tango.BL.Enumerations.LiquidTypes)"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public double GetLiquidVolumeOutputOrZero(
    LiquidTypes liquidType
)

Parameters

liquidType
Type: LiquidTypes

[Missing <param name="liquidType"/> documentation for "M:Tango.PPC.Shared.Statistics.PresentationBrushStop.GetLiquidVolumeOutputOrZero(Tango.BL.Enumerations.LiquidTypes)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Tango.PPC.Shared.Statistics.PresentationBrushStop.GetLiquidVolumeOutputOrZero(Tango.BL.Enumerations.LiquidTypes)"]

See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationBrushStop.GetVolumeInputs Method

PresentationBrushStopGetVolumeInputs Method

[Missing <summary> documentation for "M:Tango.PPC.Shared.Statistics.PresentationBrushStop.GetVolumeInputs"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<PresentationLiquidVolume> GetVolumeInputs()

Return Value

Type: ListPresentationLiquidVolume

[Missing <returns> documentation for "M:Tango.PPC.Shared.Statistics.PresentationBrushStop.GetVolumeInputs"]

See Also

Reference

PresentationBrushStop Class
Tango.PPC.Shared.Statistics Namespace


PresentationJob Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.PresentationJob"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsPresentationJob

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class PresentationJob

The PresentationJob type exposes the following members.

Constructors
 | Name | Description
Public method | PresentationJob | Initializes a new instance of the PresentationJob class
Top
Properties
 | Name | Description
Public property | ID |
Public property | Segments |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


PresentationJob Constructor

Initializes a new instance of the PresentationJob class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public PresentationJob()
See Also

Reference

PresentationJob Class
Tango.PPC.Shared.Statistics Namespace


PresentationJob Properties

The PresentationJob type exposes the following members.

Properties
 | Name | Description
Public property | ID |
Public property | Segments |
Top
See Also

Reference

PresentationJob Class
Tango.PPC.Shared.Statistics Namespace


PresentationJob.ID Property

PresentationJobID Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationJob.ID"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int ID { get; set; }

Property Value

Type: Int32
See Also

Reference

PresentationJob Class
Tango.PPC.Shared.Statistics Namespace


PresentationJob.Segments Property

PresentationJobSegments Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationJob.Segments"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<PresentationSegment> Segments { get; set; }

Property Value

Type: ListPresentationSegment
See Also

Reference

PresentationJob Class
Tango.PPC.Shared.Statistics Namespace


PresentationJob Methods

The PresentationJob type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PresentationJob Class
Tango.PPC.Shared.Statistics Namespace


PresentationLiquidVolume Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.PresentationLiquidVolume"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsPresentationLiquidVolume

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class PresentationLiquidVolume

The PresentationLiquidVolume type exposes the following members.

Constructors
 | Name | Description
Public method | PresentationLiquidVolume | Initializes a new instance of the PresentationLiquidVolume class
Top
Properties
 | Name | Description
Public property | LiquidType |
Public property | Volume |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


PresentationLiquidVolume Constructor

Initializes a new instance of the PresentationLiquidVolume class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public PresentationLiquidVolume()
See Also

Reference

PresentationLiquidVolume Class
Tango.PPC.Shared.Statistics Namespace


PresentationLiquidVolume Properties

The PresentationLiquidVolume type exposes the following members.

Properties
 | Name | Description
Public property | LiquidType |
Public property | Volume |
Top
See Also

Reference

PresentationLiquidVolume Class
Tango.PPC.Shared.Statistics Namespace


PresentationLiquidVolume.LiquidType Property

PresentationLiquidVolumeLiquidType Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationLiquidVolume.LiquidType"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public LiquidType LiquidType { get; set; }

Property Value

Type: LiquidType
See Also

Reference

PresentationLiquidVolume Class
Tango.PPC.Shared.Statistics Namespace


PresentationLiquidVolume.Volume Property

PresentationLiquidVolumeVolume Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationLiquidVolume.Volume"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public double Volume { get; set; }

Property Value

Type: Double
See Also

Reference

PresentationLiquidVolume Class
Tango.PPC.Shared.Statistics Namespace


PresentationLiquidVolume Methods

The PresentationLiquidVolume type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PresentationLiquidVolume Class
Tango.PPC.Shared.Statistics Namespace


PresentationSegment Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.PresentationSegment"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsPresentationSegment

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class PresentationSegment

The PresentationSegment type exposes the following members.

Constructors
 | Name | Description
Public method | PresentationSegment | Initializes a new instance of the PresentationSegment class
Top
Properties
 | Name | Description
Public property | Length |
Public property | Stops |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


PresentationSegment Constructor

Initializes a new instance of the PresentationSegment class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public PresentationSegment()
See Also

Reference

PresentationSegment Class
Tango.PPC.Shared.Statistics Namespace


PresentationSegment Properties

The PresentationSegment type exposes the following members.

Properties
 | Name | Description
Public property | Length |
Public property | Stops |
Top
See Also

Reference

PresentationSegment Class
Tango.PPC.Shared.Statistics Namespace


PresentationSegment.Length Property

PresentationSegmentLength Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationSegment.Length"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public int Length { get; set; }

Property Value

Type: Int32
See Also

Reference

PresentationSegment Class
Tango.PPC.Shared.Statistics Namespace


PresentationSegment.Stops Property

PresentationSegmentStops Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.PresentationSegment.Stops"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<PresentationBrushStop> Stops { get; set; }

Property Value

Type: ListPresentationBrushStop
See Also

Reference

PresentationSegment Class
Tango.PPC.Shared.Statistics Namespace


PresentationSegment Methods

The PresentationSegment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PresentationSegment Class
Tango.PPC.Shared.Statistics Namespace


RequiredFiltersData Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.RequiredFiltersData"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsRequiredFiltersData

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class RequiredFiltersData

The RequiredFiltersData type exposes the following members.

Constructors
 | Name | Description
Public method | RequiredFiltersData | Initializes a new instance of the RequiredFiltersData class
Top
Properties
 | Name | Description
Public property | Jobs |
Public property | Rmls |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


RequiredFiltersData Constructor

Initializes a new instance of the RequiredFiltersData class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public RequiredFiltersData()
See Also

Reference

RequiredFiltersData Class
Tango.PPC.Shared.Statistics Namespace


RequiredFiltersData Properties

The RequiredFiltersData type exposes the following members.

Properties
 | Name | Description
Public property | Jobs |
Public property | Rmls |
Top
See Also

Reference

RequiredFiltersData Class
Tango.PPC.Shared.Statistics Namespace


RequiredFiltersData.Jobs Property

RequiredFiltersDataJobs Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.RequiredFiltersData.Jobs"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<string> Jobs { get; set; }

Property Value

Type: ListString
See Also

Reference

RequiredFiltersData Class
Tango.PPC.Shared.Statistics Namespace


RequiredFiltersData.Rmls Property

RequiredFiltersDataRmls Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.RequiredFiltersData.Rmls"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<ThreadFilterData> Rmls { get; set; }

Property Value

Type: ListThreadFilterData
See Also

Reference

RequiredFiltersData Class
Tango.PPC.Shared.Statistics Namespace


RequiredFiltersData Methods

The RequiredFiltersData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RequiredFiltersData Class
Tango.PPC.Shared.Statistics Namespace


StartJobRunsStreamingRequest Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.StartJobRunsStreamingRequest"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsStartJobRunsStreamingRequest

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class StartJobRunsStreamingRequest

The StartJobRunsStreamingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | StartJobRunsStreamingRequest | Initializes a new instance of the StartJobRunsStreamingRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


StartJobRunsStreamingRequest Constructor

Initializes a new instance of the StartJobRunsStreamingRequest class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public StartJobRunsStreamingRequest()
See Also

Reference

StartJobRunsStreamingRequest Class
Tango.PPC.Shared.Statistics Namespace


StartJobRunsStreamingRequest Methods

The StartJobRunsStreamingRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StartJobRunsStreamingRequest Class
Tango.PPC.Shared.Statistics Namespace


StartJobRunsStreamingResponse Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.StartJobRunsStreamingResponse"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsStartJobRunsStreamingResponse

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class StartJobRunsStreamingResponse

The StartJobRunsStreamingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | StartJobRunsStreamingResponse | Initializes a new instance of the StartJobRunsStreamingResponse class
Top
Properties
 | Name | Description
Public property | JobRunComposition |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


StartJobRunsStreamingResponse Constructor

Initializes a new instance of the StartJobRunsStreamingResponse class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public StartJobRunsStreamingResponse()
See Also

Reference

StartJobRunsStreamingResponse Class
Tango.PPC.Shared.Statistics Namespace


StartJobRunsStreamingResponse Properties

The StartJobRunsStreamingResponse type exposes the following members.

Properties
 | Name | Description
Public property | JobRunComposition |
Top
See Also

Reference

StartJobRunsStreamingResponse Class
Tango.PPC.Shared.Statistics Namespace


StartJobRunsStreamingResponse.JobRunComposition Property

StartJobRunsStreamingResponseJobRunComposition Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.StartJobRunsStreamingResponse.JobRunComposition"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public JobRunComposition JobRunComposition { get; set; }

Property Value

Type: JobRunComposition
See Also

Reference

StartJobRunsStreamingResponse Class
Tango.PPC.Shared.Statistics Namespace


StartJobRunsStreamingResponse Methods

The StartJobRunsStreamingResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StartJobRunsStreamingResponse Class
Tango.PPC.Shared.Statistics Namespace


StatisticsResult Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.StatisticsResult"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsStatisticsResult

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class StatisticsResult

The StatisticsResult type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsResult | Initializes a new instance of the StatisticsResult class
Top
Properties
 | Name | Description
Public property | JobRuns |
Public property | LiquidTypes |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


StatisticsResult Constructor

Initializes a new instance of the StatisticsResult class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public StatisticsResult()
See Also

Reference

StatisticsResult Class
Tango.PPC.Shared.Statistics Namespace


StatisticsResult Properties

The StatisticsResult type exposes the following members.

Properties
 | Name | Description
Public property | JobRuns |
Public property | LiquidTypes |
Top
See Also

Reference

StatisticsResult Class
Tango.PPC.Shared.Statistics Namespace


StatisticsResult.JobRuns Property

StatisticsResultJobRuns Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.StatisticsResult.JobRuns"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<JobRunComposition> JobRuns { get; set; }

Property Value

Type: ListJobRunComposition
See Also

Reference

StatisticsResult Class
Tango.PPC.Shared.Statistics Namespace


StatisticsResult.LiquidTypes Property

StatisticsResultLiquidTypes Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.StatisticsResult.LiquidTypes"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public List<LiquidTypeDTO> LiquidTypes { get; set; }

Property Value

Type: ListLiquidTypeDTO
See Also

Reference

StatisticsResult Class
Tango.PPC.Shared.Statistics Namespace


StatisticsResult Methods

The StatisticsResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StatisticsResult Class
Tango.PPC.Shared.Statistics Namespace


StopJobRunsStreamingRequest Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.StopJobRunsStreamingRequest"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsStopJobRunsStreamingRequest

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class StopJobRunsStreamingRequest

The StopJobRunsStreamingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | StopJobRunsStreamingRequest | Initializes a new instance of the StopJobRunsStreamingRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


StopJobRunsStreamingRequest Constructor

Initializes a new instance of the StopJobRunsStreamingRequest class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public StopJobRunsStreamingRequest()
See Also

Reference

StopJobRunsStreamingRequest Class
Tango.PPC.Shared.Statistics Namespace


StopJobRunsStreamingRequest Methods

The StopJobRunsStreamingRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StopJobRunsStreamingRequest Class
Tango.PPC.Shared.Statistics Namespace


StopJobRunsStreamingResponse Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.StopJobRunsStreamingResponse"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsStopJobRunsStreamingResponse

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class StopJobRunsStreamingResponse

The StopJobRunsStreamingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | StopJobRunsStreamingResponse | Initializes a new instance of the StopJobRunsStreamingResponse class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


StopJobRunsStreamingResponse Constructor

Initializes a new instance of the StopJobRunsStreamingResponse class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public StopJobRunsStreamingResponse()
See Also

Reference

StopJobRunsStreamingResponse Class
Tango.PPC.Shared.Statistics Namespace


StopJobRunsStreamingResponse Methods

The StopJobRunsStreamingResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StopJobRunsStreamingResponse Class
Tango.PPC.Shared.Statistics Namespace


ThreadFilterData Class

[Missing <summary> documentation for "T:Tango.PPC.Shared.Statistics.ThreadFilterData"]

Inheritance Hierarchy
SystemObject
Tango.PPC.Shared.StatisticsThreadFilterData

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public class ThreadFilterData

The ThreadFilterData type exposes the following members.

Constructors
 | Name | Description
Public method | ThreadFilterData | Initializes a new instance of the ThreadFilterData class
Top
Properties
 | Name | Description
Public property | Guid |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tango.PPC.Shared.Statistics Namespace


ThreadFilterData Constructor

Initializes a new instance of the ThreadFilterData class

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public ThreadFilterData()
See Also

Reference

ThreadFilterData Class
Tango.PPC.Shared.Statistics Namespace


ThreadFilterData Properties

The ThreadFilterData type exposes the following members.

Properties
 | Name | Description
Public property | Guid |
Public property | Name |
Top
See Also

Reference

ThreadFilterData Class
Tango.PPC.Shared.Statistics Namespace


ThreadFilterData.Guid Property

ThreadFilterDataGuid Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.ThreadFilterData.Guid"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string Guid { get; set; }

Property Value

Type: String
See Also

Reference

ThreadFilterData Class
Tango.PPC.Shared.Statistics Namespace


ThreadFilterData.Name Property

ThreadFilterDataName Property

[Missing <summary> documentation for "P:Tango.PPC.Shared.Statistics.ThreadFilterData.Name"]

Namespace: Tango.PPC.Shared.Statistics
Assembly: Tango.PPC.Shared (in Tango.PPC.Shared.dll) Version: 1.0.0.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

ThreadFilterData Class
Tango.PPC.Shared.Statistics Namespace


ThreadFilterData Methods

The ThreadFilterData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThreadFilterData Class
Tango.PPC.Shared.Statistics Namespace